summaryrefslogtreecommitdiff
path: root/test/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile')
-rw-r--r--test/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/test/Makefile b/test/Makefile
index d9437bf..3252374 100644
--- a/test/Makefile
+++ b/test/Makefile
@@ -1,10 +1,13 @@
+export BUILDDIR ?= $(or $(TMPDIR),/tmp)/dbscripts-build
+COVERAGE_DIR ?= $(CURDIR)/../coverage
+
test:
PATH=$(CURDIR)/../:$(CURDIR)/../cron-jobs/:$(PATH) bats cases
test-coverage:
PATH=$(CURDIR)/../:$(CURDIR)/../cron-jobs/:$(PATH) kcov \
--include-path=$(CURDIR)/../ \
- --exclude-path=$(CURDIR)/../test,$(CURDIR)/../cron-jobs/makepkg.conf,$(CURDIR)/../config \
+ --exclude-path=$(CURDIR)/../test,$(CURDIR)/../config \
$(COVERAGE_DIR) \
bats cases