summaryrefslogtreecommitdiff
path: root/src/icedove-branding
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2021-04-22 08:43:14 +0200
committerbill-auger <mr.j.spam.me@gmail.com>2023-03-31 05:37:53 -0400
commit1799cfd3ac481046fd517761cd865726af0c93b7 (patch)
treecc3d91c7aefe81ac408a38beb0bc17448d4ddba7 /src/icedove-branding
parentbfbb860c213baff6b16cf7a4a938eda2c25e1c42 (diff)
update for v78.9
Diffstat (limited to 'src/icedove-branding')
-rw-r--r--src/icedove-branding/Makefile.in29
-rw-r--r--src/icedove-branding/branding.nsi16
-rw-r--r--src/icedove-branding/jar.mn6
-rw-r--r--src/icedove-branding/locales/jar.mn6
-rw-r--r--src/icedove-branding/moz.build37
5 files changed, 34 insertions, 60 deletions
diff --git a/src/icedove-branding/Makefile.in b/src/icedove-branding/Makefile.in
deleted file mode 100644
index 1573672..0000000
--- a/src/icedove-branding/Makefile.in
+++ /dev/null
@@ -1,29 +0,0 @@
-# This Source Code Form is subject to the terms of the Mozilla Public
-# License, v. 2.0. If a copy of the MPL was not distributed with this
-# file, You can obtain one at http://mozilla.org/MPL/2.0/.
-
-# Branding Makefile for Icedove branding
-
-include $(topsrcdir)/config/rules.mk
-
-MAIL_APP_FILES = \
- default16.png \
- default22.png \
- default24.png \
- default32.png \
- default48.png \
- default256.png \
- $(NULL)
-
-GARBAGE += $(MAIL_APP_FILES)
-
-export:: $(MAIL_APP_FILES)
- $(NSINSTALL) -D $(DIST)/branding
- cp $^ $(DIST)/branding/
-
-default16.png: SIZE=16
-default22.png: SIZE=22
-default24.png: SIZE=24
-default32.png: SIZE=32
-default48.png: SIZE=48
-default256.png: SIZE=256
diff --git a/src/icedove-branding/branding.nsi b/src/icedove-branding/branding.nsi
deleted file mode 100644
index 3ad1594..0000000
--- a/src/icedove-branding/branding.nsi
+++ /dev/null
@@ -1,16 +0,0 @@
-# This Source Code Form is subject to the terms of the Mozilla Public
-# # License, v. 2.0. If a copy of the MPL was not distributed with this
-# # file, You can obtain one at http://mozilla.org/MPL/2.0/.
-
-# NSIS defines for nightly builds.
-# The release build branding.nsi is located in other-license/branding/thunderbird/
-
-# BrandFullNameInternal is used for some registry and file system values
-# instead of BrandFullName and typically should not be modified.
-!define BrandFullNameInternal "Parabola Icedove"
-!define BrandFullName "Parabola Icedove"
-!define CompanyName "Parabola GNU/Linux-libre"
-!define URLInfoAbout "https://wiki.parabola.nu/Icedove"
-!define URLUpdateInfo "https://wiki.parabola.nu/Icedove"
-!define URLSystemRequirements "https://wiki.parabola.nu/Icedove"
-!define SurveyURL "https://wiki.parabola.nu/Icedove"
diff --git a/src/icedove-branding/jar.mn b/src/icedove-branding/jar.mn
index 434d05a..e219bd6 100644
--- a/src/icedove-branding/jar.mn
+++ b/src/icedove-branding/jar.mn
@@ -1,7 +1,4 @@
#filter substitution
-# This Source Code Form is subject to the terms of the Mozilla Public
-# License, v. 2.0. If a copy of the MPL was not distributed with this
-# file, You can obtain one at http://mozilla.org/MPL/2.0/.
messenger.jar:
% content branding %content/branding/
@@ -10,5 +7,6 @@ messenger.jar:
content/branding/about.png (content/about.png)
content/branding/icon48.png (default48.png)
content/branding/icon64.png (default64.png)
+ content/branding/icon128.png (default128.png)
content/branding/aboutDialog.css (content/aboutDialog.css)
- ../classic/skin/classic/messenger/icons/new-mail-alert.png (default48.png)
+ ../classic/skin/classic/messenger/icons/new-mail-alert.png (default48.png)
diff --git a/src/icedove-branding/locales/jar.mn b/src/icedove-branding/locales/jar.mn
index 708e5c9..e66c4a9 100644
--- a/src/icedove-branding/locales/jar.mn
+++ b/src/icedove-branding/locales/jar.mn
@@ -1,4 +1,10 @@
#filter substitution
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+[localization] @AB_CD@.jar:
+ branding (en-US/**/*.ftl)
@AB_CD@.jar:
% locale branding @AB_CD@ %locale/@AB_CD@/branding/
diff --git a/src/icedove-branding/moz.build b/src/icedove-branding/moz.build
index e53e1c4..626c0d2 100644
--- a/src/icedove-branding/moz.build
+++ b/src/icedove-branding/moz.build
@@ -7,15 +7,30 @@ DIRS += ['locales']
JAR_MANIFESTS += ['jar.mn']
-JS_PREFERENCE_FILES += ['thunderbird-branding.js']
+@template
+def ThunderbirdBranding():
+ JS_PREFERENCE_FILES += [
+ 'thunderbird-branding.js',
+ ]
-FINAL_TARGET_FILES.chrome.icons.default += [
- 'default128.png',
- 'default16.png',
- 'default22.png',
- 'default24.png',
- 'default256.png',
- 'default32.png',
- 'default48.png',
- 'default64.png',
-]
+ if CONFIG['MOZ_WIDGET_TOOLKIT'] == 'windows':
+ FINAL_TARGET_FILES += [
+ 'thunderbird.VisualElementsManifest.xml',
+ ]
+ FINAL_TARGET_FILES.VisualElements += [
+ 'VisualElements_150.png',
+ 'VisualElements_70.png',
+ ]
+ elif CONFIG['MOZ_WIDGET_TOOLKIT'] == 'gtk':
+ FINAL_TARGET_FILES.chrome.icons.default += [
+ 'default128.png',
+ 'default16.png',
+ 'default22.png',
+ 'default24.png',
+ 'default256.png',
+ 'default32.png',
+ 'default48.png',
+ 'default64.png',
+ ]
+
+ThunderbirdBranding()