summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorAndreas Grapentin <andreas@grapentin.org>2019-11-15 21:45:36 +0100
committerbill-auger <mr.j.spam.me@gmail.com>2020-06-25 05:09:52 -0400
commit26d03a3fda014c968fec664eb3d97414bfb2abc1 (patch)
treec95bda065cc601f3059e84fa821e40a7986c5f73 /src
parentfaec5fdd9d5d99baaffbf6dc3b569cd7297e6e90 (diff)
importing 69-1 branding69.0-1
Diffstat (limited to 'src')
-rw-r--r--src/patches/iceweasel-branding/Determine-which-phishing-shavar-to-use.patch26
-rw-r--r--src/patches/iceweasel-branding/Use-MOZ_APP_DISPLAYNAME-to-fill-appstrings.patch65
-rw-r--r--src/patches/iceweasel-branding/Use-firefox-instead-of-MOZ_APP_NAME-for-profile.patch35
-rw-r--r--src/patches/series6
4 files changed, 129 insertions, 3 deletions
diff --git a/src/patches/iceweasel-branding/Determine-which-phishing-shavar-to-use.patch b/src/patches/iceweasel-branding/Determine-which-phishing-shavar-to-use.patch
new file mode 100644
index 0000000..b120020
--- /dev/null
+++ b/src/patches/iceweasel-branding/Determine-which-phishing-shavar-to-use.patch
@@ -0,0 +1,26 @@
+diff --git a/modules/libpref/init/all.js b/modules/libpref/init/all.js
+index e205cd4c55..d12adbb558 100644
+--- a/modules/libpref/init/all.js
++++ b/modules/libpref/init/all.js
+@@ -5206,9 +5206,7 @@ pref("dom.mapped_arraybuffer.enabled", true);
+
+ // The tables used for Safebrowsing phishing and malware checks
+ pref("urlclassifier.malwareTable", "goog-malware-proto,goog-unwanted-proto,moztest-harmful-simple,moztest-malware-simple,moztest-unwanted-simple");
+-#ifdef MOZILLA_OFFICIAL
+-// In official builds, we are allowed to use Google's private phishing
+-// list (see bug 1288840).
++#ifdef MOZ_OFFICIAL_BRANDING
+ pref("urlclassifier.phishTable", "goog-phish-proto,moztest-phish-simple");
+ #else
+ pref("urlclassifier.phishTable", "googpub-phish-proto,moztest-phish-simple");
+diff --git a/modules/libpref/moz.build b/modules/libpref/moz.build
+index 9b7620dbca..877ebf9034 100644
+--- a/modules/libpref/moz.build
++++ b/modules/libpref/moz.build
+@@ -61,3 +61,6 @@ else:
+ FINAL_TARGET_PP_FILES += [
+ 'greprefs.js',
+ ]
++
++if CONFIG['MOZ_OFFICIAL_BRANDING']:
++ DEFINES['MOZ_OFFICIAL_BRANDING'] = True
diff --git a/src/patches/iceweasel-branding/Use-MOZ_APP_DISPLAYNAME-to-fill-appstrings.patch b/src/patches/iceweasel-branding/Use-MOZ_APP_DISPLAYNAME-to-fill-appstrings.patch
new file mode 100644
index 0000000..b2ef791
--- /dev/null
+++ b/src/patches/iceweasel-branding/Use-MOZ_APP_DISPLAYNAME-to-fill-appstrings.patch
@@ -0,0 +1,65 @@
+diff --git a/browser/locales/Makefile.in b/browser/locales/Makefile.in
+index 894e3e0..73f5378 100644
+--- a/browser/locales/Makefile.in
++++ b/browser/locales/Makefile.in
+@@ -11,6 +11,8 @@ SUBMAKEFILES += \
+ $(DEPTH)/$(MOZ_BRANDING_DIRECTORY)/locales/Makefile \
+ $(NULL)
+
++DEFINES += -DMOZ_APP_DISPLAYNAME=$(MOZ_APP_DISPLAYNAME)
++
+ # This makefile uses variable overrides from the libs-% target to
+ # build non-default locales to non-default dist/ locations. Be aware!
+
+diff --git a/browser/locales/en-US/chrome/overrides/appstrings.properties b/browser/locales/en-US/chrome/overrides/appstrings.properties
+index 05cf816..5301b0b 100644
+--- a/browser/locales/en-US/chrome/overrides/appstrings.properties
++++ b/browser/locales/en-US/chrome/overrides/appstrings.properties
+@@ -3,25 +3,25 @@
+ # file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+ malformedURI2=Please check that the URL is correct and try again.
+-fileNotFound=Firefox can’t find the file at %S.
++#expand fileNotFound=__MOZ_APP_DISPLAYNAME__ can’t find the file at %S.
+ fileAccessDenied=The file at %S is not readable.
+ dnsNotFound2=We can’t connect to the server at %S.
+-unknownProtocolFound=Firefox doesn’t know how to open this address, because one of the following protocols (%S) isn’t associated with any program or is not allowed in this context.
+-connectionFailure=Firefox can’t establish a connection to the server at %S.
++#expand unknownProtocolFound=__MOZ_APP_DISPLAYNAME__ doesn’t know how to open this address, because one of the following protocols (%S) isn’t associated with any program or is not allowed in this context.
++#expand connectionFailure=__MOZ_APP_DISPLAYNAME__ can’t establish a connection to the server at %S.
+ netInterrupt=The connection to %S was interrupted while the page was loading.
+ netTimeout=The server at %S is taking too long to respond.
+-redirectLoop=Firefox has detected that the server is redirecting the request for this address in a way that will never complete.
++#expand redirectLoop=__MOZ_APP_DISPLAYNAME__ has detected that the server is redirecting the request for this address in a way that will never complete.
+ ## LOCALIZATION NOTE (confirmRepostPrompt): In this item, don’t translate "%S"
+ confirmRepostPrompt=To display this page, %S must send information that will repeat any action (such as a search or order confirmation) that was performed earlier.
+ resendButton.label=Resend
+-unknownSocketType=Firefox doesn’t know how to communicate with the server.
++#expand unknownSocketType=__MOZ_APP_DISPLAYNAME__ doesn’t know how to communicate with the server.
+ netReset=The connection to the server was reset while the page was loading.
+ notCached=This document is no longer available.
+-netOffline=Firefox is currently in offline mode and can’t browse the Web.
++#expand netOffline=__MOZ_APP_DISPLAYNAME__ is currently in offline mode and can’t browse the Web.
+ isprinting=The document cannot change while Printing or in Print Preview.
+-deniedPortAccess=This address uses a network port which is normally used for purposes other than Web browsing. Firefox has canceled the request for your protection.
+-proxyResolveFailure=Firefox is configured to use a proxy server that can’t be found.
+-proxyConnectFailure=Firefox is configured to use a proxy server that is refusing connections.
++#expand deniedPortAccess=This address uses a network port which is normally used for purposes other than Web browsing. __MOZ_APP_DISPLAYNAME__ has canceled the request for your protection.
++#expand proxyResolveFailure=__MOZ_APP_DISPLAYNAME__ is configured to use a proxy server that can’t be found.
++#expand proxyConnectFailure=__MOZ_APP_DISPLAYNAME__ is configured to use a proxy server that is refusing connections.
+ contentEncodingError=The page you are trying to view cannot be shown because it uses an invalid or unsupported form of compression.
+ unsafeContentType=The page you are trying to view cannot be shown because it is contained in a file type that may not be safe to open. Please contact the website owners to inform them of this problem.
+ externalProtocolTitle=External Protocol Request
+@@ -36,9 +36,9 @@ unwantedBlocked=The site at %S has been
+ deceptiveBlocked=This web page at %S has been reported as a deceptive site and has been blocked based on your security preferences.
+ cspBlocked=This page has a content security policy that prevents it from being loaded in this way.
+ corruptedContentErrorv2=The site at %S has experienced a network protocol violation that cannot be repaired.
+-remoteXUL=This page uses an unsupported technology that is no longer available by default in Firefox.
++#expand remoteXUL=This page uses an unsupported technology that is no longer available by default in __MOZ_APP_DISPLAYNAME__.
+ ## LOCALIZATION NOTE (sslv3Used) - Do not translate "%S".
+-sslv3Used=Firefox cannot guarantee the safety of your data on %S because it uses SSLv3, a broken security protocol.
++#expand sslv3Used=__MOZ_APP_DISPLAYNAME__ cannot guarantee the safety of your data on %S because it uses SSLv3, a broken security protocol.
+ inadequateSecurityError=The website tried to negotiate an inadequate level of security.
+ blockedByPolicy=Your organization has blocked access to this page or website.
+-networkProtocolError=Firefox has experienced a network protocol violation that cannot be repaired.
++#expand networkProtocolError=__MOZ_APP_DISPLAYNAME__ has experienced a network protocol violation that cannot be repaired.
diff --git a/src/patches/iceweasel-branding/Use-firefox-instead-of-MOZ_APP_NAME-for-profile.patch b/src/patches/iceweasel-branding/Use-firefox-instead-of-MOZ_APP_NAME-for-profile.patch
new file mode 100644
index 0000000..dad8a5c
--- /dev/null
+++ b/src/patches/iceweasel-branding/Use-firefox-instead-of-MOZ_APP_NAME-for-profile.patch
@@ -0,0 +1,35 @@
+From: Mike Hommey <mh@glandium.org>
+Date: Sun, 11 May 2014 15:08:37 +0900
+Subject: Use "firefox" instead of MOZ_APP_NAME for profile reset
+
+---
+ toolkit/modules/ResetProfile.jsm | 2 +-
+ toolkit/xre/nsAppRunner.cpp | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/toolkit/modules/ResetProfile.jsm b/toolkit/modules/ResetProfile.jsm
+index 52c35c7..af2c0cf 100644
+--- a/toolkit/modules/ResetProfile.jsm
++++ b/toolkit/modules/ResetProfile.jsm
+@@ -9,7 +9,7 @@ var EXPORTED_SYMBOLS = ["ResetProfile"];
+ const {Services} = ChromeUtils.import("resource://gre/modules/Services.jsm");
+ const {AppConstants} = ChromeUtils.import("resource://gre/modules/AppConstants.jsm");
+
+-const MOZ_APP_NAME = AppConstants.MOZ_APP_NAME;
++const MOZ_APP_NAME = "firefox";
+ const MOZ_BUILD_APP = AppConstants.MOZ_BUILD_APP;
+
+ var ResetProfile = {
+diff --git a/toolkit/xre/nsAppRunner.cpp b/toolkit/xre/nsAppRunner.cpp
+index fe63faa..66ca008 100644
+--- a/toolkit/xre/nsAppRunner.cpp
++++ b/toolkit/xre/nsAppRunner.cpp
+@@ -4377,7 +4377,7 @@ nsresult XREMain::XRE_mainRun() {
+ if (gDoProfileReset) {
+ // Automatically migrate from the current application if we just
+ // reset the profile.
+- aKey = MOZ_APP_NAME;
++ aKey = "firefox";
+ gResetOldProfile->GetName(aName);
+ }
+ pm->Migrate(&mDirProvider, aKey, aName);
diff --git a/src/patches/series b/src/patches/series
index 08a5de2..3c9dfc1 100644
--- a/src/patches/series
+++ b/src/patches/series
@@ -1,6 +1,6 @@
-iceweasel-branding/Use-MOZ_APP_DISPLAYNAME-to-fill-appstrings.propertie.patch
-iceweasel-branding/Determine-which-phishing-shavar-to-use-depending-on-.patch
-iceweasel-branding/Use-firefox-instead-of-MOZ_APP_NAME-for-profile-rese.patch
+iceweasel-branding/Use-MOZ_APP_DISPLAYNAME-to-fill-appstrings.patch
+iceweasel-branding/Determine-which-phishing-shavar-to-use.patch
+iceweasel-branding/Use-firefox-instead-of-MOZ_APP_NAME-for-profile.patch
iceweasel-branding/Allowed-dupes_for_Iceweasel.patch
iceweasel-branding/enable-object-directory-paths.patch
iceweasel-branding/remove-default-and-shell-icons-in-packaging-manifest.patch