summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@parabola.nu>2018-08-25 17:29:32 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2018-10-23 21:24:47 -0400
commit50e76939d930a072f76eea8d522422c29e49a251 (patch)
tree93475d98b0abd80182267e52f695e84cd7ea709b /src
parentaa41d6d1f7d406803047023bc6446e3907a7d25c (diff)
branding: Fix for v60/v6161.0.2-1.parabola1
- Makefile.in doesn't respect VPATH - firefox-branding.js uses lockPref(), which no longer exists I don't know why we wanted to disable browser.startup.homepage_override.mstone anyway, I disagree with that call. - brand.dtd sets trademarkInfo.part2, which no longer exists - brand.properties doesn't set syncBrandShortName - brand.ftl doesn't exist, but it needs to
Diffstat (limited to 'src')
-rw-r--r--src/branding/Makefile.in2
-rw-r--r--src/branding/firefox-branding.js1
-rw-r--r--src/branding/locales/en-US/brand.dtd1
-rw-r--r--src/branding/locales/en-US/brand.ftl2
-rw-r--r--src/branding/locales/en-US/brand.properties2
5 files changed, 5 insertions, 3 deletions
diff --git a/src/branding/Makefile.in b/src/branding/Makefile.in
index b395c62..deed5a6 100644
--- a/src/branding/Makefile.in
+++ b/src/branding/Makefile.in
@@ -20,7 +20,7 @@ GARBAGE += $(BROWSER_APP_FILES)
export:: $(BROWSER_APP_FILES)
$(NSINSTALL) -D $(DIST)/branding
- cp $(BROWSER_APP_FILES) $(DIST)/branding/
+ cp $^ $(DIST)/branding/
GARBAGE += iceweasel.png
diff --git a/src/branding/firefox-branding.js b/src/branding/firefox-branding.js
index 17cf43e..e92356e 100644
--- a/src/branding/firefox-branding.js
+++ b/src/branding/firefox-branding.js
@@ -1,4 +1,3 @@
-lockPref("browser.startup.homepage_override.mstone", "ignore");
pref("browser.aboutHomeSnippets.updateUrl", "data:text/html,");
pref("startup.homepage_override_url","");
pref("startup.homepage_welcome_url","");
diff --git a/src/branding/locales/en-US/brand.dtd b/src/branding/locales/en-US/brand.dtd
index 50c20d6..c83e6d0 100644
--- a/src/branding/locales/en-US/brand.dtd
+++ b/src/branding/locales/en-US/brand.dtd
@@ -3,4 +3,3 @@
<!ENTITY brandFullName "Iceweasel">
<!ENTITY vendorShortName "Mozilla">
<!ENTITY trademarkInfo.part1 " ">
-<!ENTITY trademarkInfo.part2 " ">
diff --git a/src/branding/locales/en-US/brand.ftl b/src/branding/locales/en-US/brand.ftl
new file mode 100644
index 0000000..ca180e0
--- /dev/null
+++ b/src/branding/locales/en-US/brand.ftl
@@ -0,0 +1,2 @@
+-brand-short-name = Iceweasel
+-vendor-short-name = Mozilla
diff --git a/src/branding/locales/en-US/brand.properties b/src/branding/locales/en-US/brand.properties
index b69ae8d..ea073d6 100644
--- a/src/branding/locales/en-US/brand.properties
+++ b/src/branding/locales/en-US/brand.properties
@@ -2,3 +2,5 @@ brandShorterName=Iceweasel
brandShortName=Iceweasel
brandFullName=Iceweasel
vendorShortName=Mozilla
+
+syncBrandShortName=Sync