summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
Diffstat (limited to 'src')
-rw-r--r--src/branding/Makefile.in4
-rw-r--r--src/branding/locales/Makefile.in2
-rw-r--r--src/branding/locales/moz.build8
-rw-r--r--src/patches/iceweasel-branding/Use-MOZ_APP_DISPLAYNAME-to-fill-appstrings.patch13
-rw-r--r--src/patches/iceweasel-branding/rebrand-about-dialog-and-licenses-page.patch39
-rw-r--r--src/patches/series1
6 files changed, 48 insertions, 19 deletions
diff --git a/src/branding/Makefile.in b/src/branding/Makefile.in
index deed5a6..c18a877 100644
--- a/src/branding/Makefile.in
+++ b/src/branding/Makefile.in
@@ -3,10 +3,6 @@
# - copies artwork to appropriate places in objdir for bundling into app
# resources
-ifdef BRANDING_TEST
-DEFINES += -DBRANDING_TEST
-endif
-
include $(topsrcdir)/config/rules.mk
BROWSER_APP_FILES = \
diff --git a/src/branding/locales/Makefile.in b/src/branding/locales/Makefile.in
index 775c58d..e674834 100644
--- a/src/branding/locales/Makefile.in
+++ b/src/branding/locales/Makefile.in
@@ -42,6 +42,4 @@ relativesrcdir = browser/branding/iceweasel/locales
include $(DEPTH)/config/autoconf.mk
-DEFINES += -DAB_CD=$(AB_CD) -DMOZ_DISTRIBUTION_ID_UNQUOTED=$(MOZ_DISTRIBUTION_ID)
-
include $(topsrcdir)/config/rules.mk
diff --git a/src/branding/locales/moz.build b/src/branding/locales/moz.build
index 7e10323..c5d91ff 100644
--- a/src/branding/locales/moz.build
+++ b/src/branding/locales/moz.build
@@ -1 +1,9 @@
+# -*- Mode: python; indent-tabs-mode: nil; tab-width: 40 -*-
+# vim: set filetype=python:
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+DEFINES['MOZ_DISTRIBUTION_ID_UNQUOTED'] = CONFIG['MOZ_DISTRIBUTION_ID']
+
JAR_MANIFESTS += ['jar.mn']
diff --git a/src/patches/iceweasel-branding/Use-MOZ_APP_DISPLAYNAME-to-fill-appstrings.patch b/src/patches/iceweasel-branding/Use-MOZ_APP_DISPLAYNAME-to-fill-appstrings.patch
index b2ef791..98e8a56 100644
--- a/src/patches/iceweasel-branding/Use-MOZ_APP_DISPLAYNAME-to-fill-appstrings.patch
+++ b/src/patches/iceweasel-branding/Use-MOZ_APP_DISPLAYNAME-to-fill-appstrings.patch
@@ -1,16 +1,3 @@
-diff --git a/browser/locales/Makefile.in b/browser/locales/Makefile.in
-index 894e3e0..73f5378 100644
---- a/browser/locales/Makefile.in
-+++ b/browser/locales/Makefile.in
-@@ -11,6 +11,8 @@ SUBMAKEFILES += \
- $(DEPTH)/$(MOZ_BRANDING_DIRECTORY)/locales/Makefile \
- $(NULL)
-
-+DEFINES += -DMOZ_APP_DISPLAYNAME=$(MOZ_APP_DISPLAYNAME)
-+
- # This makefile uses variable overrides from the libs-% target to
- # build non-default locales to non-default dist/ locations. Be aware!
-
diff --git a/browser/locales/en-US/chrome/overrides/appstrings.properties b/browser/locales/en-US/chrome/overrides/appstrings.properties
index 05cf816..5301b0b 100644
--- a/browser/locales/en-US/chrome/overrides/appstrings.properties
diff --git a/src/patches/iceweasel-branding/rebrand-about-dialog-and-licenses-page.patch b/src/patches/iceweasel-branding/rebrand-about-dialog-and-licenses-page.patch
new file mode 100644
index 0000000..a3a4c03
--- /dev/null
+++ b/src/patches/iceweasel-branding/rebrand-about-dialog-and-licenses-page.patch
@@ -0,0 +1,39 @@
+diff --git a/browser/base/content/aboutDialog.xhtml b/browser/base/content/aboutDialog.xhtml
+index 69cbf846bb..a8491c096f 100644
+--- a/browser/base/content/aboutDialog.xhtml
++++ b/browser/base/content/aboutDialog.xhtml
+@@ -137,8 +137,8 @@
+ <label is="text-link" useoriginprincipal="true" href="about:credits" data-l10n-name="community-creditsLink"></label>
+ </description>
+ <description class="text-blurb" id="contributeDesc" data-l10n-id="helpus">
+- <label is="text-link" href="https://donate.mozilla.org/?utm_source=firefox&#38;utm_medium=referral&#38;utm_campaign=firefox_about&#38;utm_content=firefox_about" data-l10n-name="helpus-donateLink"></label>
+- <label is="text-link" href="http://www.mozilla.org/contribute/" data-l10n-name="helpus-getInvolvedLink"></label>
++ <label is="text-link" href="https://wiki.parabola.nu/Donations" data-l10n-name="helpus-donateLink"></label>
++ <label is="text-link" href="https://wiki.parabola.nu/How_to_help" data-l10n-name="helpus-getInvolvedLink"></label>
+ </description>
+ </vbox>
+ </vbox>
+diff --git a/browser/base/content/overrides/app-license.html b/browser/base/content/overrides/app-license.html
+index e7a158c792..290abbe35d 100644
+--- a/browser/base/content/overrides/app-license.html
++++ b/browser/base/content/overrides/app-license.html
+@@ -2,5 +2,5 @@
+ - License, v. 2.0. If a copy of the MPL was not distributed with this
+ - file, You can obtain one at http://mozilla.org/MPL/2.0/. -->
+ <p><b>Binaries</b> of this product have been made available to you by the
+- <a href="http://www.mozilla.org/">Mozilla Project</a> under the Mozilla
++ <a href="https://www.parabola.nu/">Parabola GNU/Linux-libre project</a> under the Mozilla
+ Public License 2.0 (MPL). <a href="about:rights">Know your rights</a>.</p>
+diff --git a/browser/locales/en-US/browser/aboutDialog.ftl b/browser/locales/en-US/browser/aboutDialog.ftl
+index 157ab9470b..3390bb2987 100644
+--- a/browser/locales/en-US/browser/aboutDialog.ftl
++++ b/browser/locales/en-US/browser/aboutDialog.ftl
+@@ -39,7 +39,7 @@ warningDesc-version = { -brand-short-name } is experimental and may be unstable.
+
+ community-exp = <label data-l10n-name="community-exp-mozillaLink">{ -vendor-short-name }</label> is a <label data-l10n-name="community-exp-creditsLink">global community</label> working together to keep the Web open, public and accessible to all.
+
+-community-2 = { -brand-short-name } is designed by <label data-l10n-name="community-mozillaLink">{ -vendor-short-name }</label>, a <label data-l10n-name="community-creditsLink">global community</label> working together to keep the Web open, public and accessible to all.
++community-2 = { -brand-short-name } is developed by the Parabola project and is based on Mozilla Firefox. Parabola GNU/Linux-libre and { -brand-short-name } are not officially associated with Mozilla or its products.
+
+ helpus = Want to help? <label data-l10n-name="helpus-donateLink">Make a donation</label> or <label data-l10n-name="helpus-getInvolvedLink">get involved!</label>
+
diff --git a/src/patches/series b/src/patches/series
index 3c9dfc1..49bf172 100644
--- a/src/patches/series
+++ b/src/patches/series
@@ -4,3 +4,4 @@ iceweasel-branding/Use-firefox-instead-of-MOZ_APP_NAME-for-profile.patch
iceweasel-branding/Allowed-dupes_for_Iceweasel.patch
iceweasel-branding/enable-object-directory-paths.patch
iceweasel-branding/remove-default-and-shell-icons-in-packaging-manifest.patch
+iceweasel-branding/rebrand-about-dialog-and-licenses-page.patch