summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Ismael Haase Hernandez <hahj87@gmail.com>2011-05-26 10:28:04 -0500
committerJoshua Ismael Haase Hernandez <hahj87@gmail.com>2011-05-26 10:28:04 -0500
commit2d16cd342cc654a82d374dcff538da0e21e24dca (patch)
tree518fc28475b128ec5b66fce8590407e36a7d0aa5
parent6515ca8157b42a3c4a6bb5b6173375d6eb052eb2 (diff)
* fullpkg-ng logs not found deps
* Added FULLBUILDCMD to libretools.conf check
-rwxr-xr-xfullpkg-ng5
-rw-r--r--libretools.conf3
2 files changed, 5 insertions, 3 deletions
diff --git a/fullpkg-ng b/fullpkg-ng
index 4159320..a35eab3 100755
--- a/fullpkg-ng
+++ b/fullpkg-ng
@@ -150,7 +150,7 @@ function find_deps {
popd > /dev/null
} && break 1 # found, go to next dep
- # search pkgname in repo if that doesn't work
+ # if search pkgname in repo doesn't work
# this should find pkgsplits
_dir=$(find "$ABSROOT/${_repo}" -type f -name PKGBUILD -print0 | \
"xargs" -0 -e grep -H -Ew grep $_dep > /dev/null ) && {
@@ -160,6 +160,7 @@ function find_deps {
[ $? -eq 20 ] && return 20
popd > /dev/null
} && break 1 # found, go to next dep
+ echo "dep_not_found:$_dep" >> $tempdir/log
done
done
unset next_level dir
@@ -278,7 +279,7 @@ while [ ${#build_packages[@]} -gt 0 ]; do
$FULLBUILDCMD; r=$?
case $r in
0) plain "The build was succesful."
- source .INFO && [ -n $repo ] && librestage $repo || \
+ source .INFO && [ -n $repo ] && librestage $repo || \
echo "unstaged:$(basename $PWD)" >> $build_dir/log
echo "built:$(basename $PWD)" >> $build_dir/log
cleanup "$(basename $PWD)"
diff --git a/libretools.conf b/libretools.conf
index 70479a3..eb0a1ff 100644
--- a/libretools.conf
+++ b/libretools.conf
@@ -58,7 +58,8 @@ ABSLIBREGIT=http://projects.parabolagnulinux.org/abslibre.git/
# Checks if vars aren't empty
for VAR in CHROOTDIR CHROOT CHCOPY CACHEDIR PARABOLAHOST LIBREDESTDIR \
- LIBRESRCDIR BLACKLIST WORKDIR PATCHDIR REPOS ARCHES ABSLIBREGIT COMMITCMD DIFFTOOL; do
+ LIBRESRCDIR BLACKLIST WORKDIR PATCHDIR REPOS ARCHES ABSLIBREGIT \
+ COMMITCMD DIFFTOOL FULLBUILDCMD; do
[[ -z ${!VAR} ]] && {
echo "Configure $VAR var in /etc/libretools.conf"