summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-06-02 13:31:17 -0500
committerJoshua Ismael Haase Hernández <hahj87@gmail.com>2011-06-02 14:12:49 -0500
commitf0f010772d651e09f957f9b47057e81e7737ad45 (patch)
tree912fb2eb8145c33c92403ab7032ad20d03294f73
parentaf74e1a5884a23e29289c661c74fadbf72d794e7 (diff)
fullpkg shows guessed dir
libretools.conf has reordered repos before community
-rwxr-xr-xfullpkg7
-rw-r--r--libretools.conf2
2 files changed, 5 insertions, 4 deletions
diff --git a/fullpkg b/fullpkg
index 14c4e9f..a95f59d 100755
--- a/fullpkg
+++ b/fullpkg
@@ -161,11 +161,12 @@ function find_deps {
# if search pkgname in repo doesn't work
# this should find pkgsplits
- elif _dir=($(find "$ABSROOT/${_repo}" -type f -name PKGBUILD -print0 | \
- "xargs" -0 -e grep -HEw "pkgname=|pkgbase=|provides=" | grep $_dep 2>&1));
+ elif _dir=($(find "$ABSROOT/${_repo}" -type f -name PKGBUILD -print0 2>/dev/null | \
+ "xargs" -0 -e grep -HEw "pkgname=|pkgbase=|provides=" | grep -w "$_dep" 2>&1));
then
+ _dir=$(dirname $(echo $_dir | cut -d: -f1))
plain "guess for $_dep -> $_dir"
- pushd $(dirname $(echo $_dir | cut -d: -f1)) > /dev/null
+ pushd $_dir > /dev/null
$0 -c -d ${build_dir} -l ${next_level}
# Circular deps must fail
[ $? -eq 20 ] && return 20
diff --git a/libretools.conf b/libretools.conf
index 4badc5c..c4ac606 100644
--- a/libretools.conf
+++ b/libretools.conf
@@ -10,7 +10,7 @@ WORKDIR=/home/$USER/packages
# Tip: As early repos take precedence on $REPOS loops, you can use this as
# inverted order of precedence. Put testing repos first so fullpkg find new
# PKGBUILDs first, for instance.
-REPOS=('libre' 'libre-testing' 'core' 'community' 'extra' 'social' 'sugar')
+REPOS=('core' 'extra' 'community' 'libre' 'libre-testing' 'social' 'sugar')
# The architectures
ARCHES=('i686' 'x86_64' 'mips64el' 'any')