summaryrefslogtreecommitdiff
path: root/fullpkg
diff options
context:
space:
mode:
authorNicolas Reynolds <fauno@kiwwwi.com.ar>2011-04-17 20:22:56 -0300
committerNicolas Reynolds <fauno@kiwwwi.com.ar>2011-04-17 20:22:56 -0300
commit45c3f66474e470e4d5fd36837ec00d37fdb65b26 (patch)
tree24b45f40c3cea81b60a2827fb522768a3cd91aa4 /fullpkg
parentd119fb5b5d48412fa4cf15abfd788c44128cdf2f (diff)
guess repo
Diffstat (limited to 'fullpkg')
-rwxr-xr-xfullpkg12
1 files changed, 9 insertions, 3 deletions
diff --git a/fullpkg b/fullpkg
index e810942..696e97f 100755
--- a/fullpkg
+++ b/fullpkg
@@ -30,6 +30,10 @@ source /etc/libretools.conf
# TODO
# * Check for concurrence
+guess_repo() {
+ basename $(dirname $(pwd))
+}
+
# Get the queue list from the server
get_queue() {
rsync -e ssh -aq $PARABOLAHOST:mips64el/queue $queue_file >/dev/null 2>&1 || {
@@ -99,8 +103,10 @@ quit() {
exit 1
}
+repo=${1:-$(guess_repo)}
+
source PKGBUILD
-msg "Building ${pkgbase:-${pkgname[@]}}: $pkgdesc"
+msg "Building ${repo:-missing repo}/${pkgbase:-${pkgname[@]}}: $pkgdesc"
is_built "${pkgbase:-${pkgname[0]}}>=${pkgver}" && exit 0
@@ -162,7 +168,7 @@ for _dep in ${deps[@]}; do
# Enter the work dir and run this command in it
pushd $tmp_dir/$_dep >/dev/null
- $0
+ $0 $_repo
[[ $? -ne 0 ]] && {
failed=(${failed[@]} $_dep)
@@ -212,7 +218,7 @@ case $r in
msg "The build was succesful."
mipsrelease *.pkg.tar.*
- librestage ${1:-$(basename $(dirname $PWD))}
+ librestage $repo
sudo pacman -Sy
;;