summaryrefslogtreecommitdiff
path: root/src/abslibre-tools
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2017-04-20 23:05:42 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2017-05-04 14:30:02 -0400
commit7d584af432202470d9d8fefd74a7f7ed044c4ab3 (patch)
tree0db3e165bd055a5f56c1a8548333b0dc87c27774 /src/abslibre-tools
parent2ae5371f347603d34a7ccc33681e612db338d11e (diff)
random tidy up
Diffstat (limited to 'src/abslibre-tools')
-rwxr-xr-xsrc/abslibre-tools/diff-unfree10
1 files changed, 5 insertions, 5 deletions
diff --git a/src/abslibre-tools/diff-unfree b/src/abslibre-tools/diff-unfree
index 3670f7f..2d54379 100755
--- a/src/abslibre-tools/diff-unfree
+++ b/src/abslibre-tools/diff-unfree
@@ -25,8 +25,6 @@
. "$(librelib messages)"
. "$(librelib conf)"
-load_files libretools
-check_vars libretools DIFFPROG || exit 1
usage() {
print "Usage: %s [community|packages] [unfree-package] [repo]" "${0##*/}"
@@ -39,9 +37,11 @@ usage() {
main() {
if [[ "$1" == "--help" ]]; then
usage
- exit 0
+ return 0
fi
+ load_files libretools
+ check_vars libretools DIFFPROG || return 1
local package_guess=${PWD##*/}
local repo=${1:-$(basename "${PWD%/*}")}
@@ -57,14 +57,14 @@ main() {
if [[ ! -r PKGBUILD ]]; then
error "This is not a build dir."
- exit 1
+ return 1
fi
tmp_dir="$(mktemp --tmpdir -d "${package}.XXXXXX")"
if [[ ! -d "${tmp_dir}" ]]; then
error "Can't create temp dir"
- exit 1
+ return 1
fi
unfree_dir="${tmp_dir}/${svnrepo}/${package}/${trunk}"