summaryrefslogtreecommitdiff
path: root/src/aur
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-05-24 14:04:41 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-05-24 14:04:41 -0400
commitd71e71cf7367778df0039d4624b76b2575823a5b (patch)
treee8c9798302349b41811ee0ead89869b478c692b9 /src/aur
parentb8282547fba55b655ad82c34369cf9d0a5c81e3b (diff)
remove stdnull, use plain I/O redirection
Diffstat (limited to 'src/aur')
-rwxr-xr-xsrc/aur8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/aur b/src/aur
index 12efb81..c9ab267 100755
--- a/src/aur
+++ b/src/aur
@@ -53,7 +53,7 @@ main() {
else
# Store our copy of the PKGBUILD dir
_diff="${PWD}/${_pkg}"
- stdnull "pushd $(mktemp --tmpdir -d ${_pkg}.XXXX)"
+ pushd $(mktemp --tmpdir -d ${_pkg}.XXXX) &>/dev/null
msg2 "Downloading PKGBUILD into ${PWD} for diff"
fi
fi
@@ -67,7 +67,7 @@ main() {
continue
fi
- stdnull "pushd $_pkg"
+ pushd $_pkg &>/dev/null
if [[ ! -z "$_diff" ]]; then
msg2 "Diffing files"
@@ -77,7 +77,7 @@ main() {
done
# Go back to our copy to continue working
- stdnull "pushd ${_diff}"
+ pushd ${_diff} &>/dev/null
fi
. PKGBUILD
@@ -119,7 +119,7 @@ main() {
fi
done
- stdnull popd
+ popd &>/dev/null
done
[[ ${#missing_deps[*]} -gt 0 ]] && {