summaryrefslogtreecommitdiff
path: root/src/fullpkg
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-10-26 01:35:45 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-10-26 17:18:11 -0400
commit23faa9361d79d1d88754a1e1e5aa9f040b34545c (patch)
tree2a0dcd569de702c6f697c5e5536c5ddd07c8146e /src/fullpkg
parent99933725329dc760f5cc704b3fd20f033dafdd14 (diff)
Merge pkgbuild-check-{nonfree,licenses}, add a summarize tool for it.
This should fix a number of bugs in those two scripts, and the summarize script simplifies aur and libremakepkg:hooks-check.sh
Diffstat (limited to 'src/fullpkg')
-rwxr-xr-xsrc/fullpkg/fullpkg-build7
-rwxr-xr-xsrc/fullpkg/fullpkg-find7
2 files changed, 2 insertions, 12 deletions
diff --git a/src/fullpkg/fullpkg-build b/src/fullpkg/fullpkg-build
index e922877..8149453 100755
--- a/src/fullpkg/fullpkg-build
+++ b/src/fullpkg/fullpkg-build
@@ -29,11 +29,8 @@ list_pkgs() {
check_nonfree() {
find "$build_dir" -name PKGBUILD \
-exec pkgbuild-check-nonfree {} +
- if [ "$?" -eq 15 ]; then
- error "Some PKGBUILD have nonfree problems"
- exit 15
- fi
-
+ local s=$?
+ pkgbuild-summarize-nonfree -q $s || return $s
}
# Removes a package from the buildorder
diff --git a/src/fullpkg/fullpkg-find b/src/fullpkg/fullpkg-find
index 007c53c..566605a 100755
--- a/src/fullpkg/fullpkg-find
+++ b/src/fullpkg/fullpkg-find
@@ -93,13 +93,6 @@ find_deps() {
local repo="${repo:-$(guess_repo)}"
local pkgbase="${pkgbase:-${pkgname[0]}}"
- if ! pkgbuild-check-nonfree > /dev/null 2> /dev/null; then
- if [ "$?" -eq 15 ]; then
- error "%s has nonfree issues" "$pkgbase"
- return 15
- fi
- fi
-
# Checking any package built, since otherwise e.g. kdebase would
# be always considered outdated: there is no package built named kdebase.
# TODO: maybe check for the package requested in case of recursive calls,