summaryrefslogtreecommitdiff
path: root/src/lib
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2018-07-31 14:41:36 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2018-07-31 14:41:36 -0400
commit12a6aad73c4d48a89e020899b643ea495143e298 (patch)
treedcce42b77a3f6ede208b30fd476ede7938124ed7 /src/lib
parent64a2d1c9fb7900c2002ce3871444d06d93854538 (diff)
Begone with XBS
Diffstat (limited to 'src/lib')
-rw-r--r--src/lib/conf.sh.3.ronn4
-rw-r--r--src/lib/conf.sh.in7
2 files changed, 2 insertions, 9 deletions
diff --git a/src/lib/conf.sh.3.ronn b/src/lib/conf.sh.3.ronn
index 92267fb..ad146da 100644
--- a/src/lib/conf.sh.3.ronn
+++ b/src/lib/conf.sh.3.ronn
@@ -105,8 +105,8 @@ These two routines deal with loading `PKGBUILD`(5) files.
The differences in behavior for anything that takes a slug comes down
to the differences in the output for `list_files` and `list_envvars`.
-The "known" slugs are "abs", "makepkg", "libretools", and anything
-beginning with "xbs". If anything else is given, then:
+The "known" slugs are "abs", "makepkg", and "libretools". If anything
+else is given, then:
* `list_files` will give back "/etc/libretools.d/<SLUG>.conf" and
"$<XDG_CONFIG_HOME>/libretools/<SLUG>.conf"
diff --git a/src/lib/conf.sh.in b/src/lib/conf.sh.in
index 36efe21..0cd0a03 100644
--- a/src/lib/conf.sh.in
+++ b/src/lib/conf.sh.in
@@ -66,10 +66,6 @@ list_files() {
fi
fi
;;
- xbs*)
- echo "${sysconfdir}/xbs/$slug.conf"
- echo "$XDG_CONFIG_HOME/xbs/$slug.conf"
- ;;
libretools)
echo "${sysconfdir}/$slug.conf"
echo "$XDG_CONFIG_HOME/libretools/$slug.conf"
@@ -98,9 +94,6 @@ list_envvars() {
libretools)
printf '%s\n' DIFFPROG
;;
- xbs)
- printf '%s\n' BUILDSYSTEM
- ;;
*) :;;
esac
}