summaryrefslogtreecommitdiff
path: root/src/lib
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2017-02-15 18:55:25 -0500
committerLuke Shumaker <lukeshu@lukeshu.com>2017-04-11 13:02:27 -0400
commit74067d389c204cd40906980391680724380667c0 (patch)
tree654f7aaed07e8fe019893337256929db87a017a1 /src/lib
parent2e798795833af72ba0618f5577f15488b201b0fa (diff)
Expect devtools files to already be patched.
Diffstat (limited to 'src/lib')
-rw-r--r--src/lib/Makefile16
-rw-r--r--src/lib/common.sh.head25
-rw-r--r--src/lib/common.sh.tail1
3 files changed, 0 insertions, 42 deletions
diff --git a/src/lib/Makefile b/src/lib/Makefile
index eb2ffde..7c573de 100644
--- a/src/lib/Makefile
+++ b/src/lib/Makefile
@@ -8,22 +8,6 @@ libretools.out.libs += common.sh conf.sh
$(outdir)/conf.sh: $(var.)sysconfdir $(var.)pkgconfdir
-$(outdir)/common.sh: $(outdir)/%: $(srcdir)/%.in $(srcdir)/%.head $(srcdir)/%.tail $(outdir)/Makefile
- @echo "OUT $@"
- @{ \
- cat '$(<D)/$*.head' && \
- echo && \
- sed -r \
- -e '/encoding problem/d;/LANG=/d' \
- -e 's/mesg=\$$(.)/mesg="$$(_ "$$\1")"/' \
- -e 's/gettext /_l _ /g' \
- -e "s/^(\s+)(msg|error) '/\1_l \2 '/" \
- -e 's|lock\(\)\s*\{|lock()\n{|' \
- '$(<D)/$*.in' && \
- echo && \
- cat '$(<D)/$*.tail' && \
- :; } > '$@'
-
# Translate ##########################################################
$(outdir)/blacklist.sh.pot: $(srcdir)/blacklist.sh $(srcdir)/librexgettext
diff --git a/src/lib/common.sh.head b/src/lib/common.sh.head
deleted file mode 100644
index 23bfeb8..0000000
--- a/src/lib/common.sh.head
+++ /dev/null
@@ -1,25 +0,0 @@
-#!/hint/bash
-# This may be included with or without `set -euE`
-
-# This file is included by libremessages.
-# You should probably use libremessages instead of this.
-
-# License: Unspecified
-
-shopt -s extglob
-
-if [[ -z ${_INCLUDE_COMMON_SH:-} ]]; then
-_INCLUDE_COMMON_SH=true
-
-[[ -n ${TEXTDOMAIN:-} ]] || export TEXTDOMAIN='libretools'
-[[ -n ${TEXTDOMAINDIR:-} ]] || export TEXTDOMAINDIR='/usr/share/locale'
-
-if type gettext &>/dev/null; then
- _() { gettext "$@"; }
-else
- _() { echo "$@"; }
-fi
-
-_l() {
- TEXTDOMAIN='librelib' TEXTDOMAINDIR='/usr/share/locale' "$@"
-}
diff --git a/src/lib/common.sh.tail b/src/lib/common.sh.tail
deleted file mode 100644
index e133fad..0000000
--- a/src/lib/common.sh.tail
+++ /dev/null
@@ -1 +0,0 @@
-fi