summaryrefslogtreecommitdiff
path: root/src/librefetch/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2018-08-26 16:23:41 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2018-08-26 16:27:43 -0400
commite7edcfde77b0752480db7b4ede5f1a541ee97a88 (patch)
treee8334af8fc5ee4a2c73a792c4311ff05fe2b1374 /src/librefetch/Makefile
parent3d380700d49dd6faeb793834079724b5c0b93e92 (diff)
librefetch: Drop a file in /etc/makepkg.d/ rather than editing makepkg.conf
The librefetch-install program will stick around for a while (1 year; 2019-08-26) so that it can be used from a post_upgrade hook to remove the old edits, in order to seamlessly migrate people. https://git.parabola.nu/abslibre.git/commit/?id=73982c5ad7057ce2fdec669d962aec6c9caf28c8
Diffstat (limited to 'src/librefetch/Makefile')
-rw-r--r--src/librefetch/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/src/librefetch/Makefile b/src/librefetch/Makefile
index f11f0ed..cee8ca8 100644
--- a/src/librefetch/Makefile
+++ b/src/librefetch/Makefile
@@ -2,12 +2,17 @@ include $(dir $(lastword $(MAKEFILE_LIST)))/../../config.mk
include $(topsrcdir)/build-aux/Makefile.head.mk
libretools.out.bins = librefetch librefetch-install
-libretools.out.confs = $(libretools.src.conf) librefetch-makepkg.conf
+libretools.out.confs = $(libretools.src.conf)
libretools.out.libexecs = $(filter librefetchdir/%,$(libretools.src.exec))
libretools.out.libs = $(filter-out $(libretools.out.libexecs),$(filter librefetchdir/%,$(libretools.src.git)))
libretools.pots = $(libretools.out.bins)
+libretools.out = makepkg-librefetch.conf
-$(outdir)/librefetch-install: $(var.)pkgconfdir
-$(outdir)/librefetch-makepkg.conf: $(var.)bindir
+files.sys.all += /etc/makepkg.d/librefetch.conf
+
+$(outdir)/makepkg-librefetch.conf: $(var.)bindir
+
+$(DESTDIR)/etc/makepkg.d/librefetch.conf: $(outdir)/makepkg-librefetch.conf
+ install -T -Dm644 '$<' '$@'
include $(topsrcdir)/build-aux/Makefile.tail.mk