summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorLuke T. Shumaker <lukeshu@parabola.nu>2024-04-02 18:17:48 -0600
committerLuke T. Shumaker <lukeshu@parabola.nu>2024-04-03 23:20:19 -0600
commit6b9ebf370bd1f146b4aa4cd035a6c4d53d588895 (patch)
tree592670fdf5ad6dd49348e133d81e9160d9c577bc /src
parent287897b6a58fcc4ab0fbca604517fdb38b505ac9 (diff)
librefetch: Update for makepkg 6.1.0
Diffstat (limited to 'src')
-rwxr-xr-xsrc/librefetch/librefetch3
-rw-r--r--src/librefetch/librefetchdir/Makefile3
-rwxr-xr-xsrc/librefetch/librefetchdir/makepkg.gen2
3 files changed, 3 insertions, 5 deletions
diff --git a/src/librefetch/librefetch b/src/librefetch/librefetch
index 972b3cc..0a1bb70 100755
--- a/src/librefetch/librefetch
+++ b/src/librefetch/librefetch
@@ -222,8 +222,7 @@ doit() {
mv -f "$base_dst" "$dst"
fi
else
-# FIXME: this LOC breaks mksource()
-# export PKGEXT=${base_dst##*/} # so the file uses the correct compression
+ export PKGEXT=${base_dst##*/} # so the file uses the correct compression
export PKGDEST=${dst%/*}
export pkg_file=$dst
diff --git a/src/librefetch/librefetchdir/Makefile b/src/librefetch/librefetchdir/Makefile
index ed7b510..6646b22 100644
--- a/src/librefetch/librefetchdir/Makefile
+++ b/src/librefetch/librefetchdir/Makefile
@@ -21,11 +21,10 @@
# You should have received a copy of the GNU General Public License
# along with LibreFetch. If not, see <http://www.gnu.org/licenses/>.
-# new =
librefetchdir := $(dir $(lastword $(MAKEFILE_LIST)))
old_makepkg := $(shell which makepkg)
-old_library := $(shell $(shell grep LIBRARY= $(old_makepkg)); echo $$LIBRARY)
+old_library := $(shell $(shell grep MAKEPKG_LIBRARY= $(old_makepkg)); echo $$MAKEPKG_LIBRARY)
new_makepkg = $(new)/makepkg
new_library = $(new)/libmakepkg
diff --git a/src/librefetch/librefetchdir/makepkg.gen b/src/librefetch/librefetchdir/makepkg.gen
index 31cdfe6..f1958f8 100755
--- a/src/librefetch/librefetchdir/makepkg.gen
+++ b/src/librefetch/librefetchdir/makepkg.gen
@@ -20,7 +20,7 @@
# You should have received a copy of the GNU General Public License
# along with LibreFetch. If not, see <http://www.gnu.org/licenses/>.
-/LIBRARY=/iexport LIBRARY="${0%/*}/libmakepkg"
+/MAKEPKG_LIBRARY=/iexport MAKEPKG_LIBRARY="${0%/*}/libmakepkg"
/create_package\(\) \{/,/^\}$/ {
# Don't generate metadata files