summaryrefslogtreecommitdiff
path: root/test/librechroot-test.sh
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2018-08-26 17:10:13 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2018-08-26 17:58:39 -0400
commit320419d272295e0fca26c5ee134609e406e63ddc (patch)
treeea9d81c68c0fef710bcd1257de07f93f56ee0195 /test/librechroot-test.sh
parente7edcfde77b0752480db7b4ede5f1a541ee97a88 (diff)
test: librechroot: Check whether chcleanup can install libretools [ci-skip]
Diffstat (limited to 'test/librechroot-test.sh')
-rw-r--r--test/librechroot-test.sh16
1 files changed, 15 insertions, 1 deletions
diff --git a/test/librechroot-test.sh b/test/librechroot-test.sh
index 00ca2ed..93e7833 100644
--- a/test/librechroot-test.sh
+++ b/test/librechroot-test.sh
@@ -71,7 +71,7 @@ it_obeys_depends_in_PKGBUILD() {
not testsudo librechroot -l "$roundup_test_name" run lsof
# Make sure it leaves it with the PKGBUILD
testsudo librechroot -l "$roundup_test_name" install-name lsof
- testsudo librechroot -l "$roundup_test_name" run sh -c 'printf "%s\n" "$1" > /startdir/PKGBUILD' -- "$(cat librechroot.d/PKGBUILD)"
+ testsudo librechroot -l "$roundup_test_name" run sh -c 'printf "%s\n" "$1" > /startdir/PKGBUILD' -- "$(cat librechroot.d/PKGBUILD-arches)"
# uid=99 is 'nobody', but we say '99' because sometimes 'nobody' is uid=65534.
# https://bugs.archlinux.org/task/56828
testsudo librechroot -l "$roundup_test_name" run chown -R 99:99 /startdir
@@ -79,6 +79,20 @@ it_obeys_depends_in_PKGBUILD() {
testsudo librechroot -l "$roundup_test_name" run lsof
}
+it_can_install_libretools_with_chcleanup() {
+ require network sudo || return 0
+ libremessages msg 'Creating a chroot, may take a few minutes' &>/dev/tty
+
+ not testsudo librechroot -l "$roundup_test_name" run test -f /usr/bin/chcleanup
+ testsudo librechroot -l "$roundup_test_name" run mkdir /startdir
+ testsudo librechroot -l "$roundup_test_name" run sh -c 'printf "%s\n" "$1" > /startdir/PKGBUILD' -- "$(cat librechroot.d/PKGBUILD-libretools)"
+ # uid=99 is 'nobody', but we say '99' because sometimes 'nobody' is uid=65534.
+ # https://bugs.archlinux.org/task/56828
+ testsudo librechroot -l "$roundup_test_name" run chown -R 99:99 /startdir
+ testsudo librechroot -l "$roundup_test_name" clean-pkgs
+ testsudo librechroot -l "$roundup_test_name" run test -f /usr/bin/chcleanup
+}
+
it_displays_help_as_normal_user() {
rm -rf "$XDG_CONFIG_HOME"
LC_ALL=C librechroot help >$tmpdir/stdout 2>$tmpdir/stderr