summaryrefslogtreecommitdiff
path: root/test/librechroot.d
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2018-08-03 00:45:00 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2018-08-03 03:34:58 -0400
commit74c6b30d7dcacb59d94a023f04ba45f19643a8f4 (patch)
tree23ec048928eaf59937179e235ede4a83874faf9c /test/librechroot.d
parentd496e81f54df00a11395d296d965a6f8b3b057d5 (diff)
test: librechroot: Add failing test case for chcleanup [ci-skip]
https://labs.parabola.nu/issues/1311
Diffstat (limited to 'test/librechroot.d')
-rw-r--r--test/librechroot.d/PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/test/librechroot.d/PKGBUILD b/test/librechroot.d/PKGBUILD
new file mode 100644
index 0000000..6116ad9
--- /dev/null
+++ b/test/librechroot.d/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname='libretools-hello'
+pkgver=1.0
+license=('GPL')
+url='https://parabola.nu'
+
+pkgrel=1
+arch=(i686 x86_64)
+depends=(sh)
+depends_i686=('lsof')
+depends_x86_64=('lsof')
+
+build() {
+ cd "$srcdir"
+ echo '#!/bin/sh' > hello.sh
+ echo 'echo Hello, world!' >> hello.sh
+ echo 'lsof' >> hello.sh
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm755 hello.sh "$pkgdir"/usr/bin/libretools-hello
+}