summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--cleansystem3
-rw-r--r--doc/fullpkg7
-rwxr-xr-xfullpkg2
-rwxr-xr-xlibrerelease12
-rw-r--r--libretools.conf4
-rwxr-xr-xmips64el/mipsrelease4
-rwxr-xr-xpkgbuild-check-nonfree11
7 files changed, 31 insertions, 12 deletions
diff --git a/cleansystem b/cleansystem
index 3f92b95..5c44d17 100644
--- a/cleansystem
+++ b/cleansystem
@@ -124,3 +124,6 @@ wpa_supplicant
xfsprogs
xz
zlib
+libgssglue
+libtirpc
+
diff --git a/doc/fullpkg b/doc/fullpkg
new file mode 100644
index 0000000..5645fae
--- /dev/null
+++ b/doc/fullpkg
@@ -0,0 +1,7 @@
+# FullPKG
+FullPKG is a tool to build a package from ABS, find all needed dependencies
+along the way and build them too if necessary.
+
+## Before running fullpkg
+Update PKGBUILD path cache by running `toru -u <repo>` on your ABS root. Once
+for each repo you'll be using.
diff --git a/fullpkg b/fullpkg
index bda55e7..f242039 100755
--- a/fullpkg
+++ b/fullpkg
@@ -228,7 +228,7 @@ __build() {
echo "built:$(basename $PWD)" >>$build_dir/log
;;
-## Build failed
+# # Build failed
*)
error "There were errors while trying to build the package."
echo "failed:$(basename $PWD)" >>$build_dir/log
diff --git a/librerelease b/librerelease
index 7df5184..56cf856 100755
--- a/librerelease
+++ b/librerelease
@@ -34,6 +34,7 @@ function usage {
echo "$(gettext " -h this message.")"
echo "$(gettext " -l only list packages but not upload them.")"
echo "$(gettext " -c clean packages on $WORKDIR/staging.")"
+ echo "$(gettext " -n dry-run")"
}
function list_packages {
@@ -52,16 +53,18 @@ function clean_non_packages {
-delete
}
-# Clean everything
+# Clean everything if not on dry-run mode
function clean {
+ [ -z ${dryrun} ] && \
find ${WORKDIR}/staging/ -type f -delete
}
-while getopts 'hlc' arg; do
+while getopts 'hlcn' arg; do
case $arg in
h) usage; exit 0 ;;
l) list_packages; exit 0 ;;
- c) clean_packages; exit $? ;;
+ c) clean; exit $? ;;
+ n) dryrun="--dry-run" ;;
esac
done
@@ -72,6 +75,9 @@ done
clean_non_packages
msg "Uploading packages..."
rsync --recursive \
+ ${dryrun} \
+ --no-group \
+ --no-perms \
--copy-links \
--hard-links \
--partial \
diff --git a/libretools.conf b/libretools.conf
index c6a8245..05971d3 100644
--- a/libretools.conf
+++ b/libretools.conf
@@ -35,7 +35,7 @@ HOOKPRERELEASE="ssh -fN parabola"
## Server destination of libre packages
# Don't change unless you know what you're doing and you won't screw
# anything ;)
-LIBREDESTDIR=/home/parabolavnx/parabolagnulinux.org/repo
+LIBREDESTDIR=/srv/http/repo/public
## ABSLibre
ABSLIBREGIT=http://projects.parabolagnulinux.org/abslibre.git
@@ -63,7 +63,7 @@ TORUPATH=/var/lib/libretools/toru
# Checks if vars aren't empty
for VAR in CHROOTDIR CHROOT CACHEDIR PARABOLAHOST LIBREDESTDIR \
- BLACKLIST WORKDIR PATCHDIR REPOS ARCHES ABSLIBREGIT \
+ BLACKLIST WORKDIR REPOS ARCHES ABSLIBREGIT \
COMMITCMD DIFFTOOL FULLBUILDCMD; do
ret=0
diff --git a/mips64el/mipsrelease b/mips64el/mipsrelease
index b8ff01d..1a4aade 100755
--- a/mips64el/mipsrelease
+++ b/mips64el/mipsrelease
@@ -10,6 +10,8 @@
source /etc/makepkg.conf
source /etc/libretools.conf
+libretoolsdir="$(dirname $0)/../"
+
usage() {
echo "$0 repo package1 [ package2 ... packageN ]"
echo
@@ -53,4 +55,6 @@ pushd ${WORKDIR}/abs/${CARCH}/${repo} >/dev/null
tar xvf $SRCPKGDEST/${pkgbase:-${pkgname[0]}}-${fullver}${SRCEXT}
popd >/dev/null
+$libretoolsdir/chcleanup || true
+
exit $?
diff --git a/pkgbuild-check-nonfree b/pkgbuild-check-nonfree
index 55976a8..fd7b69e 100755
--- a/pkgbuild-check-nonfree
+++ b/pkgbuild-check-nonfree
@@ -19,6 +19,8 @@
# You should have received a copy of the GNU General Public License
# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
+source /etc/libretools.conf
+
function in_array { # usage : in_array( $needle, $haystack )
[[ $2 ]] || return 1 # Not found
@@ -30,10 +32,9 @@ function in_array { # usage : in_array( $needle, $haystack )
return 1 # Not Found
}
-
function get_blacklist { # Download the blacklist.
- pushd $XDG_CONFIG_HOME/libretools/ >/dev/null
+ pushd "$XDG_CONFIG_HOME/libretools" >/dev/null
msg "Downloading the blacklist of proprietary software packages."
wget -N -q -O blacklist.txt "${BLACKLIST}" 2>/dev/null || {
[ -e $XDG_CONFIG_HOME/libretools/blacklist.txt ] || {
@@ -47,7 +48,7 @@ function get_blacklist { # Download the blacklist.
function check_deps { # Check wheter a package depends on non-free
- pushd $XDG_CONFIG_HOME/libretools/ >/dev/null
+ pushd "$XDG_CONFIG_HOME/libretools/" >/dev/null
local unfree=($(cut -d: -f1 blacklist.txt)) # pkgname:free-replacement:comments
local freerep=($(cut -d: -f2 blacklist.txt)) # pkgname:free-replacement:comments
popd >/dev/null
@@ -72,8 +73,6 @@ function check_deps { # Check wheter a package depends on non-free
done
}
-source /etc/libretools.conf
-
if [ -e $XDG_CONFIG_HOME/libretools/libretools.conf ]; then
source $XDG_CONFIG_HOME/libretools/libretools.conf
fi
@@ -89,7 +88,7 @@ else
fi
if [ ! -d "$XDG_CONFIG_HOME/libretools" ]; then
- mkdir -p $XDG_CONFIG_HOME/libretools
+ mkdir -p "$XDG_CONFIG_HOME/libretools"
fi
get_blacklist