summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xtoru4
1 files changed, 2 insertions, 2 deletions
diff --git a/toru b/toru
index 41acb18..de0e92f 100755
--- a/toru
+++ b/toru
@@ -137,7 +137,7 @@ update() {
fi
- package_paths=($(read_cache ${_repo}.paths))
+ package_paths=($(read_cache ${_repo}.paths || true))
# Inform how many PKGBUILDS were found and quit immediately if none
$quiet || msg "Found $((${#pkgbuilds[*]}-1)) PKGBUILDs to update"
@@ -165,7 +165,7 @@ update() {
for _pkg in ${pkgname[@]}; do
# Keep removing unneeded stuff
- unset package_${_pkg} >/dev/null 2>&1
+ unset package_${_pkg} >/dev/null 2>&1 || true
# Fill the list of packages to find
packages_in_abs+=($_pkg-$(get_full_version ${epoch:-0} $pkgver $pkgrel))
package_paths+=($_pkg:$_pkgpath)