summaryrefslogtreecommitdiff
path: root/src/chroot-tools/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/chroot-tools/Makefile')
-rw-r--r--src/chroot-tools/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/src/chroot-tools/Makefile b/src/chroot-tools/Makefile
index 96fb837..93655d7 100644
--- a/src/chroot-tools/Makefile
+++ b/src/chroot-tools/Makefile
@@ -1,27 +1,28 @@
include $(dir $(lastword $(MAKEFILE_LIST)))/../../config.mk
include $(topsrcdir)/build-aux/Makefile.head.mk
+
pkglibexecdir = $(libexecdir)/libretools/chroot
-libretools-bins = chcleanup librechroot libremakepkg
-libretools-libexecs += arch-nspawn chcleanup distcc-tool indent mkarchroot
-libretools-libs += makechrootpkg.sh
-devtools-files = makechrootpkg.sh.in mkarchroot.in arch-nspawn.in
-std.clean_files += chcleanup.lib
+libretools.src.devtools = makechrootpkg.sh.in mkarchroot.in arch-nspawn.in
+libretools.out.bins = chcleanup librechroot libremakepkg
+libretools.out.libexecs = arch-nspawn chcleanup distcc-tool indent mkarchroot
+libretools.out.libs = $(libretools.src.sh) makechrootpkg.sh
+files.out.int += chcleanup.lib
$(srcdir)/makechrootpkg.sh.in: $(srcdir)/%.sh.in: $(devtoolsdir)/%.in
cp $< $@
$(outdir)/chcleanup: $(srcdir)/chcleanup.in $(outdir)/chcleanup.lib
- m4 -I$(@D) -P $< | $(edit) | install -m755 /dev/stdin $@
+ m4 -I$(@D) -P $< | $(libretools.edit) | install -m755 /dev/stdin $@
$(outdir)/chcleanup.lib: $(call at.path,$(topoutdir)/src/lib/common.sh) $(outdir)/Makefile
bash -c '. $<; declare -f _l plain msg msg2 error' > $@
$(outdir)/distcc-tool.pot: LIBREXGETTEXT_FLAGS+=--simple=errusage
-$(DESTDIR)$(bindir)/chcleanup: $(var)bindir $(var)libexecdir
- mkdir -p $(@D)
+$(DESTDIR)$(bindir)/chcleanup: $(var.)bindir $(var.)libexecdir
+ $(MKDIR_P) $(@D)
ln -srfT $(DESTDIR)$(libexecdir)/libretools/chroot/chcleanup $@
-at.depdirs += ../lib
+at.subdirs += ../lib
include $(topsrcdir)/build-aux/Makefile.tail.mk