summaryrefslogtreecommitdiff
path: root/src/libretools.conf
diff options
context:
space:
mode:
Diffstat (limited to 'src/libretools.conf')
-rw-r--r--src/libretools.conf137
1 files changed, 137 insertions, 0 deletions
diff --git a/src/libretools.conf b/src/libretools.conf
new file mode 100644
index 0000000..5e45350
--- /dev/null
+++ b/src/libretools.conf
@@ -0,0 +1,137 @@
+#!/bin/bash
+
+################################################################################
+# misc #
+################################################################################
+
+## Blacklist URL
+## Used by `pkgbuild-check-nonfree`
+BLACKLIST=http://repo.parabolagnulinux.org/docs/blacklist.txt
+
+## Diff tool (vimdiff, gvimdiff, meld, etc)
+## Used by `aur`, `diff-unfree`
+DIFFTOOL=`which vimdiff gvimdiff meld colordiff 2>/dev/null|sed 's/\s.*//'`
+
+## The repos you'll be packaging for
+## Used by `toru`, `createworkdir`, `prfullpkg`
+# Tip: As early repos take precedence on $REPOS loops, you can use this as
+# inverted order of precedence. Put testing repos first so fullpkg find new
+# PKGBUILDs first, for instance. Toru-path uses reverse order to enforce repo
+# precedence on the path cache (the last path added replaces the rest)
+REPOS=('core' 'libre' 'extra' 'community' 'libre-testing' 'social' 'sugar' 'pcr' 'java')
+
+## The architectures
+## Used by `librestage`
+ARCHES=('i686' 'x86_64' 'mips64el' 'any')
+
+################################################################################
+# chroot #
+################################################################################
+
+## The directory where the chroots are stored
+CHROOTDIR=/var/lib/archbuild
+## Extra packages to have installed on the chroot (besides base base-devel and sudo)
+CHROOTEXTRAPKG=(distcc ccache tsocks)
+## The meaning of this changes based on the version of libretools+devtools
+## do NOT set it to 'root'
+CHROOT=default
+
+################################################################################
+# abslibre #
+################################################################################
+
+# The dir where you work on
+WORKDIR=/home/$USER/packages
+
+## Package signing
+SIGEXT=".sig"
+#SIGID="0xYOURID"
+
+## Parabola hostname
+PARABOLAHOST=parabola
+## Assumes something similar in your .ssh/config:
+
+## Repo server
+# Host parabola
+# Port 1863
+# HostName repo.parabolagnulinux.org
+# User repo
+
+## Server destination of libre packages
+# Don't change unless you know what you're doing and you won't screw
+# anything ;)
+LIBREDESTDIR=/srv/http/repo/public
+
+## ABSLibre
+ABSLIBREGIT=http://projects.parabolagnulinux.org/abslibre.git
+
+## Commit Command
+## Should be git or hg
+## Uncomment only one of those
+COMMITCMD=git
+#COMMITCMD=hg
+
+################################################################################
+# fullpkg #
+################################################################################
+
+## Uncomment one of those or make one of your choice
+# Normal fullpkg
+FULLBUILDCMD="sudo libremakepkg"
+# Cross compiling fullkpg
+# FULLBUILDCMD="sudo libremakepkg -n cross-compile-chroot"
+# Build from within the chroot (or host system)
+# FULLBUILDCMD="makepkg -sL --noconfirm"
+
+# Run a command before releasing a package (ie. SSH connection, SSH tunnel, etc.)
+HOOKPRERELEASE="ssh -fN parabola"
+
+# Run a command before running FULLBUILDCMD, usually to cleanup uneeded packages
+# Note! chcleanup *is not* chroot aware, if you run it as it is it will cleanup
+# your system
+# HOOKPREBUILD="chcleanup"
+
+# Locally release the package or any other action after running FULLBUILDCMD
+# succesfully
+# HOOKLOCALRELEASE=""
+
+################################################################################
+# toru #
+################################################################################
+
+# Section for toru's vars
+TORUPATH=/var/lib/libretools/toru
+
+################################################################################
+# This probably shouldn't be in a .conf file... #
+################################################################################
+
+LIBREUSER="${SUDO_USER:-$USER}"
+LIBREHOME="$(eval echo ~$LIBREUSER)"
+if [[ -z ${XDG_CONFIG_HOME:-} ]]; then
+ export XDG_CONFIG_HOME="${LIBREHOME}/.config"
+fi
+if [[ -e "$XDG_CONFIG_HOME/libretools/libretools.conf" ]]; then
+ . "$XDG_CONFIG_HOME/libretools/libretools.conf"
+fi
+
+ret=0
+for VAR in CHROOTDIR CHROOT PARABOLAHOST LIBREDESTDIR \
+ BLACKLIST WORKDIR REPOS ARCHES ABSLIBREGIT \
+ COMMITCMD DIFFTOOL FULLBUILDCMD SIGEXT SIGID; do
+
+ if [[ -z ${!VAR} ]]; then
+ echo "Configure $VAR var in /etc/libretools.conf"
+ ret=1
+ fi
+done
+if [[ $CHROOT == root ]]; then
+ echo "Configured var CHROOT cannot equal 'root'"
+ ret=1
+fi
+if [[ $ret != 0 ]]; then
+ exit 1
+fi
+unset ret
+
+. /usr/bin/libremessages