summaryrefslogtreecommitdiff
path: root/test/fixtures/libremakepkg/PKGBUILD-distcc
diff options
context:
space:
mode:
Diffstat (limited to 'test/fixtures/libremakepkg/PKGBUILD-distcc')
-rw-r--r--test/fixtures/libremakepkg/PKGBUILD-distcc26
1 files changed, 13 insertions, 13 deletions
diff --git a/test/fixtures/libremakepkg/PKGBUILD-distcc b/test/fixtures/libremakepkg/PKGBUILD-distcc
index e9f1d72..7abd79d 100644
--- a/test/fixtures/libremakepkg/PKGBUILD-distcc
+++ b/test/fixtures/libremakepkg/PKGBUILD-distcc
@@ -7,23 +7,23 @@ pkgrel=1
arch=(any)
build() (
- cd "$srcdir"
- set -x
+ cd "$srcdir"
+ set -x
- # Check that the odaemon socket exists
- [[ -S /socket ]]
+ # Check that the odaemon socket exists
+ [[ -S /socket ]]
- # ... and that it works
- printf 'GET / HTTP/1.1\r\nHost: parabola.nu\r\n\r\n' | distcc-tool client parabola.nu 80 > http.txt
- [[ "$(sed 1q http.txt)" == HTTP/* ]]
+ # ... and that it works
+ printf 'GET / HTTP/1.1\r\nHost: parabola.nu\r\n\r\n' | distcc-tool client parabola.nu 80 >http.txt
+ [[ "$(sed 1q http.txt)" == HTTP/* ]]
- # ... and that idaemon talks to it
- socat TCP-CONNECT:"${DISTCC_HOSTS}" STDIO < /dev/null > hello.txt
- [[ "$(cat hello.txt)" == 'Hello, I am a distcc server' ]]
+ # ... and that idaemon talks to it
+ socat TCP-CONNECT:"${DISTCC_HOSTS}" STDIO </dev/null >hello.txt
+ [[ "$(cat hello.txt)" == 'Hello, I am a distcc server' ]]
)
package() {
- cd "$srcdir"
- install -Dm644 hello.txt "$pkgdir"/usr/share/hello.txt
- install -Dm644 http.txt "$pkgdir"/usr/share/http.txt
+ cd "$srcdir"
+ install -Dm644 hello.txt "$pkgdir"/usr/share/hello.txt
+ install -Dm644 http.txt "$pkgdir"/usr/share/http.txt
}