summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndré Fabian Silva Delgado <emulatorman@parabola.nu>2015-02-16 13:06:09 -0200
committerAndré Fabian Silva Delgado <emulatorman@parabola.nu>2015-02-16 13:06:19 -0200
commit0724f68631c267285063fc5e9ed2fc1a618c58ee (patch)
tree745af38b33890fabe4cf71469a9aeefb749efd3f
parent5725ce45eaa91eeb83f1efaed8ccedcc96a2bdc0 (diff)
import some features from old parabola-keyring
-rw-r--r--Makefile22
-rw-r--r--README.md12
2 files changed, 30 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index d99b3d7..7988ecd 100644
--- a/Makefile
+++ b/Makefile
@@ -1,3 +1,5 @@
+V=20150216
+
export LANG=C
export SHELL=/bin/bash
@@ -13,8 +15,28 @@ users = $(call dep_dir,users)
all: PHONY pacman-keyring postfix-virtual-map
+PREFIX = /usr/local
+
+install:
+ install -dm755 $(DESTDIR)$(PREFIX)/share/pacman/keyrings/
+ install -m0644 parabola{.gpg,-trusted,-revoked} $(DESTDIR)$(PREFIX)/share/pacman/keyrings/
+
+uninstall:
+ rm -f $(DESTDIR)$(PREFIX)/share/pacman/keyrings/parabola{.gpg,-trusted,-revoked}
+ rmdir -p --ignore-fail-on-non-empty $(DESTDIR)$(PREFIX)/share/pacman/keyrings/
+
+dist:
+ cp -rv output/pacman-keyring output/parabola-keyring-$(V)/
+ cp -v Makefile output/parabola-keyring-$(V)/
+ bsdtar czf output/parabola-keyring-$(V).tar.gz -C output parabola-keyring-$(V)/
+ gpg --detach-sign --use-agent output/parabola-keyring-$(V).tar.gz
+
+upload:
+ scp output/parabola-keyring-$(V).tar.gz output/parabola-keyring-$(V).tar.gz.sig parabola:/srv/repo/main/other/parabola-keyring
+
clean: PHONY
rm -rf output/cache
+
distclean: PHONY
rm -rf output
diff --git a/README.md b/README.md
index af5c8f8..9c75482 100644
--- a/README.md
+++ b/README.md
@@ -33,14 +33,18 @@ of each file.
Using the tools (make)
======================
-There are 2 `make` targets of interest: `pacman-keyring` and
-`postfix-virtual-map`. `make [all]` makes both of them. The output
-of each goes in `output/{pacman-keyring,postfix-virtual-map}`
-respectively.
+There are 4 `make` targets of interest: `pacman-keyring`, `dist`,
+`upload` and `postfix-virtual-map`. `make [all]` makes `pacman-keyring`
+and`postfix-virtual-map`. The output goes in
+`output/{pacman-keyring,postfix-virtual-map}` respectively.
`pacman-keyring` makes the Pacman keyring that we package up as the
`parabola-keyring` package.
+`dist` makes the `parabola-keyring` tarball.
+
+`upload` makes the uploading of `parabola-keyring` tarball to the server.
+
`postfix-virual-map` makes a map for postfix email aliases we provide
to our developers.