summaryrefslogtreecommitdiff
path: root/config.mk
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2018-04-26 01:38:05 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2018-04-26 01:39:57 -0400
commit9fbe238cfee84beb0e0796463f7f6b44c13cbdd3 (patch)
tree9faa155aa3d29488aa740f6b9e3d7e931bc5876e /config.mk
parent1a64603645e894fd2c886a02876762bee0b208a7 (diff)
Update dependencies
This now requires go 1.10 (because x/sys/unix) The cgo that go 1.10 ships is apparently super unhappy when `CC=gcc -std=c99`, it wants GNU dialects. So add a way to override that; set `go_CC=gcc -std=gnu99`. On the bright side, the cgo CFLAGS hacks are no longer nescessary.
Diffstat (limited to 'config.mk')
-rw-r--r--config.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/config.mk b/config.mk
index 459318c..b5a63b2 100644
--- a/config.mk
+++ b/config.mk
@@ -12,8 +12,15 @@ shadow_file = $(sysconfdir)/nshd/shadow
NET ?=
#NET ?= FORCE
user = nshd
+
+# C
CFLAGS += -Wall -Wextra -Werror -pedantic
CC = gcc -std=c99
.LIBPATTERNS = lib%.so lib%.a
+# Go
+go_CC = gcc -std=gnu99
+GOCACHE = $(topoutdir)/go/cache
+CGO_ENABLED = 1
+
endif