summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..24ca8c9
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,28 @@
+#
+# SPDX-License-Identifier: GPL-3.0-or-later
+
+PREFIX ?= /usr/local
+DOC_DIR=$(DESTDIR)$(PREFIX)/share/doc/parabolaiso-configs
+PROFILE_DIR=$(DESTDIR)$(PREFIX)/share/parabolaiso/configs
+
+DOC_FILES=$(wildcard *.rst)
+SCRIPT_FILES=$(wildcard */profiledef.sh) $(wildcard */airootfs/usr/local/bin/*)
+PROFILES=releng* lxde-openrc
+
+all:
+
+check: shellcheck
+
+shellcheck:
+ shellcheck -s bash $(SCRIPT_FILES)
+
+install: install-profiles install-doc
+
+install-profiles:
+ install -d -m 755 $(PROFILE_DIR)
+ cp -a --no-preserve=ownership $(PROFILES) $(PROFILE_DIR)/
+
+install-doc:
+ install -vDm 644 $(DOC_FILES) -t $(DOC_DIR)
+
+.PHONY: check install install-doc install-profiles shellcheck