summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2017-02-05 02:39:42 -0500
committerLuke Shumaker <lukeshu@sbcglobal.net>2017-02-05 02:39:42 -0500
commit8a11d369a63313269277ab246aba183f10f8523d (patch)
tree4586d8dae65b80d4354f15be95a397d8ae06a68e
parentcd9c64780945f9a448b1833a06074e426f3db265 (diff)
Makefile: tidy
-rw-r--r--Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 6714a78..833d50b 100644
--- a/Makefile
+++ b/Makefile
@@ -41,6 +41,9 @@ files.sys.all = $(targets) $(pkgconffile)
%: %.in .var.sbindir .var.pkgconffile .var.webuser
sed $(foreach v,$(patsubst .var.%,%,$(filter .var.%,$^)), -e 's|@$v@|$($v)|' ) < $< > $@
+%: %.c .var.LINK.c
+ $(LINK.c) $(filter-out .var.%,$^) -o $@
+
$(DESTDIR)$(sbindir)/%: %
install -Dm755 $< $@
@@ -58,9 +61,6 @@ $(DESTDIR)$(uwsgidir)/%: %
# Specific rules
-parabolaweb-changepassword: %: %.c .var.LINK.c
- $(LINK.c) $(filter-out .var.%,$^) -o $@
-
depends.txt: list-depends depends_static.txt
./$< > $@
@@ -72,5 +72,6 @@ $(DESTDIR)$(pkgconffile): parabolaweb.conf
.DELETE_ON_ERROR:
.SECONDARY:
+.SUFFIXES:
include $(topsrcdir)/build-aux/Makefile.tail.mk