summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index bbe0725..26a1f3d 100644
--- a/Makefile
+++ b/Makefile
@@ -49,9 +49,12 @@ am_sys_files = $(targets) $(pkgconffile)
# Pattern rules
-%: %.in
+%: %.in .var.sbindir .var.pkgconffile
sed -e 's|@sbindir@|$(sbindir)|' -e 's|@pkgconffile@|$(pkgconffile)|' < $< > $@
+.var.%: FORCE
+ @printf '%s' '$($*)' | ./write-ifchanged $@
+
$(DESTDIR)$(sbindir)/%: %
install -Dm755 $< $@