summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohannes Löthberg <johannes@kyriasis.com>2016-10-23 16:20:30 +0200
committerJohannes Löthberg <johannes@kyriasis.com>2016-10-23 16:20:30 +0200
commit42181f85c44de29d40642aeed897e030f30e0559 (patch)
treeb279aeb19276e0f6a3cd62e3fc50d979b1e20454 /Makefile.am
parentc965fc99c42a9fc57d6d0ba86f892950ef8558bf (diff)
Move over pacsort testsuite
Signed-off-by: Johannes Löthberg <johannes@kyriasis.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ff369d2..2b86c2c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS = src lib
+SUBDIRS = src lib test
if WANT_DOC
SUBDIRS += doc
endif
@@ -6,3 +6,13 @@ endif
DIST_SUBDIRS = $(SUBDIRS)
DISTCHECK_CONFIGURE_FLAGS = --prefix=/usr --sysconfdir=/etc --localstatedir=/var --enable-doc --disable-git-version
+
+TESTS = \
+ test/pacsorttest.sh
+
+
+TEST_SUITE_LOG = test/test-suite.log
+AM_TESTS_ENVIRONMENT = \
+ PMTEST_BIN_DIR=$(top_builddir)/src/; export PMTEST_UTIL_DIR;
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
+ $(top_srcdir)/build-aux/tap-driver.sh