summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArthur de Jong <arthur@arthurdejong.org>2011-03-31 20:16:44 +0000
committerArthur de Jong <arthur@arthurdejong.org>2011-03-31 20:16:44 +0000
commit2d0abd289968a83a2a89509fc6c8aa20fc2b4829 (patch)
tree784f87a20a7c2641a448eb9b156b301cebe599ca /Makefile.am
parentac9e380fdcbbc6c66cffe84cb5ab8ff4e8d7daf2 (diff)
use $(mkinstalldirs) instead of $(INSTALL_DATA) -D because -D is not supported on all operating systems (patch by SATOH Fumiyasu)
git-svn-id: http://arthurdejong.org/svn/nss-pam-ldapd/nss-pam-ldapd@1420 ef36b2f9-881f-0410-afb5-c4e39611909c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 261fb32..027c83d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -82,7 +82,8 @@ install-nslcd_conf:
@if [ -f $(DESTDIR)$(NSLCD_CONF_PATH) ]; then \
echo "$(DESTDIR)$(NSLCD_CONF_PATH) already exists, install will not overwrite"; \
else \
- $(INSTALL_DATA) -D $(srcdir)/nslcd.conf $(DESTDIR)$(NSLCD_CONF_PATH) || true; \
+ $(mkinstalldirs) `dirname $(DESTDIR)$(NSLCD_CONF_PATH)`; \
+ $(INSTALL_DATA) $(srcdir)/nslcd.conf $(DESTDIR)$(NSLCD_CONF_PATH); \
fi
uninstall-nslcd_conf:
-rm -f $(DESTDIR)$(NSLCD_CONF_PATH)