summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArthur de Jong <arthur@arthurdejong.org>2009-08-31 21:46:01 +0000
committerArthur de Jong <arthur@arthurdejong.org>2009-08-31 21:46:01 +0000
commiteac5616ac2b6f38a202f1038f8e9eedbfeb2fda5 (patch)
treea16ad1a5c30d2f7de37906b619296d41b1313602 /Makefile.am
parente4f7e00a9e435fcf77f2f08264c5d2788a82c297 (diff)
rename configfile to /etc/nslcd.conf and make debian packaging copy the file to the new name on upgrade
git-svn-id: http://arthurdejong.org/svn/nss-pam-ldapd/nss-ldapd@980 ef36b2f9-881f-0410-afb5-c4e39611909c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 10 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index 84e4878..e404a73 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -54,27 +54,27 @@ DEBIAN_FILES = debian/changelog debian/compat debian/control \
debian/po/POTFILES.in debian/po/templates.pot \
$(wildcard debian/po/*.po)
-EXTRA_DIST = nss-ldapd.conf nslcd.h \
+EXTRA_DIST = nslcd.conf nslcd.h \
$(wildcard m4/*.m4) HACKING $(DEBIAN_FILES)
DISTCHECK_CONFIGURE_FLAGS = --enable-warnings
ACLOCAL_AMFLAGS = -I m4
-NSS_LDAP_PATH_CONF = @NSS_LDAP_PATH_CONF@
+NSLCD_CONF_PATH = @NSLCD_CONF_PATH@
-install-data-local: install-ldap_conf
-uninstall-local: uninstall-ldap_conf
+install-data-local: install-nslcd_conf
+uninstall-local: uninstall-nslcd_conf
# install a default configuration file if it is not already there
-install-ldap_conf:
- @if [ -f $(DESTDIR)$(NSS_LDAP_PATH_CONF) ]; then \
- echo "$(DESTDIR)$(NSS_LDAP_PATH_CONF) already exists, install will not overwrite"; \
+install-nslcd_conf:
+ @if [ -f $(DESTDIR)$(NSLCD_CONF_PATH) ]; then \
+ echo "$(DESTDIR)$(NSLCD_CONF_PATH) already exists, install will not overwrite"; \
else \
- $(INSTALL_DATA) -D $(srcdir)/nss-ldapd.conf $(DESTDIR)$(NSS_LDAP_PATH_CONF); \
+ $(INSTALL_DATA) -D $(srcdir)/nslcd.conf $(DESTDIR)$(NSLCD_CONF_PATH) || true; \
fi
-uninstall-ldap_conf:
- -rm -f $(DESTDIR)$(NSS_LDAP_PATH_CONF)
+uninstall-nslcd_conf:
+ -rm -f $(DESTDIR)$(NSLCD_CONF_PATH)
# target for easily creating a Debian package
# the find is an ugly hack to fix a bug if being built on an nfs filesystem