summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..0767b86
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer (Parabola) : Aurélien DESBRIÈRES <aurelien@hackers.camp>
+
+pkgname=paraboley
+pkgver=0.1
+pkgrel=1
+pkgdesc="Python script to display system infomation alongside the Parabola GNU / Linux-libre logo."
+arch=('any')
+url="http://XL04D.github.com/paraboley"
+license=('GPL')
+depends=('python')
+makedepends=('git' 'python-distribute')
+optdepends=(
+'python-mpd-git: python libary for mpd interaction',
+'python-logbook-git: for logging'
+'imagemagick: for default screenshot command'
+)
+conflicts=()
+provides=('paraboley')
+source="git://github.com/XL04D/paraboley.git"
+
+pkgver() {
+ cd ${pkgname}
+ git describe --always | sed 's|-|.|g'
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ python setup.py install --root=${pkgdir}
+ install -D -m644 COPYING ${pkgdir}/usr/share/licenses/paraboley/COPYING
+}