summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@parabola.nu>2018-08-16 21:53:56 -0400
committerLuke Shumaker <lukeshu@parabola.nu>2018-08-16 21:53:56 -0400
commit6d135f850e76f618d130c0f051ff95682bf9b509 (patch)
treea8c6d149ec1dc9db356c1967980b9e9ec61e8229 /meson.build
parentb11f5d09ce51a2cfa09c5765eea065174a0ce3af (diff)
parent928e4346c0b9d507f571d7827a4f63028c5e0a5b (diff)
Merge tag 'systemd/v239.0-2.parabola7' into systemd/parabolaHEADsystemd/parabola
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 04331dd41a..a0e7240708 100644
--- a/meson.build
+++ b/meson.build
@@ -425,6 +425,7 @@ decl_headers = '''
#include <sys/stat.h>
'''
# FIXME: key_serial_t is only defined in keyutils.h, this is bound to fail
+# FIXME: these should use -D_GNU_SOURCE, since that is defined at build time
foreach decl : ['char16_t',
'char32_t',
@@ -439,6 +440,10 @@ foreach decl : ['char16_t',
conf.set10('HAVE_' + decl.underscorify().to_upper(), have)
endforeach
+conf.set10('HAVE_STRUCT_STATX_IN_SYS_STAT_H', cc.sizeof('struct statx', prefix : '''
+#include <sys/stat.h>
+''', args : '-D_GNU_SOURCE') > 0)
+
foreach decl : [['IFLA_INET6_ADDR_GEN_MODE', 'linux/if_link.h'],
['IN6_ADDR_GEN_MODE_STABLE_PRIVACY', 'linux/if_link.h'],
['IFLA_VRF_TABLE', 'linux/if_link.h'],