summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDavide Cavalca <dcavalca@fb.com>2018-04-09 02:43:35 -0700
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-05-08 17:33:04 +0200
commit70848ecfc6306711197394c0926e443e803ae870 (patch)
treecfcf86f0ea4f998069586e48f58741db27127920 /meson.build
parent0d6f0ea6c1994a5769704d2150ce907a1132a8c8 (diff)
meson: add support for building static libsystemd and libudev
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build21
1 files changed, 21 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 734a289755..b99e9b29fd 100644
--- a/meson.build
+++ b/meson.build
@@ -1342,6 +1342,27 @@ libsystemd = shared_library(
install : true,
install_dir : rootlibdir)
+static_libsystemd = get_option('static-libsystemd')
+static_libsystemd_pic = static_libsystemd == 'true' or static_libsystemd == 'pic'
+
+install_libsystemd_static = static_library(
+ 'systemd',
+ libsystemd_sources,
+ journal_client_sources,
+ include_directories : includes,
+ link_with : [libbasic,
+ libbasic_gcrypt],
+ build_by_default : static_libsystemd != 'false',
+ install : static_libsystemd != 'false',
+ install_dir : rootlibdir,
+ pic : static_libsystemd == 'true' or static_libsystemd == 'pic',
+ dependencies : [threads,
+ librt,
+ libxz,
+ liblz4,
+ libgcrypt],
+ c_args : libsystemd_c_args + (static_libsystemd_pic ? [] : ['-fno-PIC']))
+
############################################################
# binaries that have --help and are intended for use by humans,