summaryrefslogtreecommitdiff
path: root/pcr/libselinux/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/libselinux/PKGBUILD')
-rw-r--r--pcr/libselinux/PKGBUILD49
1 files changed, 16 insertions, 33 deletions
diff --git a/pcr/libselinux/PKGBUILD b/pcr/libselinux/PKGBUILD
index d974a108a..213c4eebc 100644
--- a/pcr/libselinux/PKGBUILD
+++ b/pcr/libselinux/PKGBUILD
@@ -6,26 +6,27 @@
# Maintainer: Luke Shumaker <lukeshu@parabola.nu>
# parabola changes and rationale:
-# - corrected license
+# - corrected license
+# - Added armv7h
pkgname=libselinux
-pkgver=2.7
+pkgver=3.2
pkgrel=1
pkgdesc="SELinux library and simple utilities"
-arch=('i686' 'x86_64' 'armv7h')
-url='http://userspace.selinuxproject.org'
+arch=('i686' 'x86_64' 'armv6h')
+arch+=(''armv7h')
+url='https://github.com/SELinuxProject/selinux'
license=('GPL2')
groups=('selinux')
-makedepends=('python2' 'python' 'ruby' 'xz' 'swig')
-depends=('libsepol' 'pcre')
-optdepends=('python2: python2 bindings'
- 'python: python bindings'
+makedepends=('pkgconf' 'python' 'ruby' 'xz' 'swig')
+depends=('libsepol>=3.2' 'pcre')
+optdepends=('python: python bindings'
'ruby: ruby bindings')
conflicts=("selinux-usr-${pkgname}")
provides=("selinux-usr-${pkgname}=${pkgver}-${pkgrel}")
-source=("https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20170804/${pkgname}-${pkgver}.tar.gz"
+source=("https://github.com/SELinuxProject/selinux/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz"
"libselinux.tmpfiles.d")
-sha256sums=('d0fec0769b3ad60aa7baf9b9a4b7a056827769dc2dadda0dc0eb59b3d1c18c57'
+sha256sums=('df758ef1d9d4811051dd901ea6b029ae334ffd7c671c128beb16bce1e25ac161'
'afe23890fb2e12e6756e5d81bad3c3da33f38a95d072731c0422fbeb0b1fa1fc')
build() {
@@ -34,9 +35,9 @@ build() {
# Do not build deprecated rpm_execcon() interface. It is useless on Arch Linux anyway.
export DISABLE_RPM=y
+ export CFLAGS="${CFLAGS} -fno-semantic-interposition"
make swigify
make all
- make PYTHON=/usr/bin/python2 pywrap
make PYTHON=/usr/bin/python3 pywrap
make RUBY=/usr/bin/ruby rubywrap
}
@@ -46,28 +47,10 @@ package() {
export DISABLE_RPM=y
- make DESTDIR="${pkgdir}" \
- LIBSEPOLA=/usr/lib/libsepol.a \
- SBINDIR="${pkgdir}/usr/bin" \
- SHLIBDIR="${pkgdir}/usr/lib" \
- install
- make DESTDIR="${pkgdir}" PYTHON=/usr/bin/python2 \
- LIBSEPOLA=/usr/lib/libsepol.a \
- SBINDIR="${pkgdir}/usr/bin" \
- SHLIBDIR="${pkgdir}/usr/lib" \
- install-pywrap
- make DESTDIR="${pkgdir}" PYTHON=/usr/bin/python3 \
- LIBSEPOLA=/usr/lib/libsepol.a \
- SBINDIR="${pkgdir}/usr/bin" \
- SHLIBDIR="${pkgdir}/usr/lib" \
- install-pywrap
- make DESTDIR="${pkgdir}" RUBY=/usr/bin/ruby \
- LIBSEPOLA=/usr/lib/libsepol.a \
- SBINDIR="${pkgdir}/usr/bin" \
- SHLIBDIR="${pkgdir}/usr/lib" \
- install-rubywrap
- /usr/bin/python2 -m compileall "${pkgdir}/$(/usr/bin/python2 -c 'import site; print(site.getsitepackages()[0])')"
- /usr/bin/python3 -m compileall "${pkgdir}/$(/usr/bin/python3 -c 'import site; print(site.getsitepackages()[0])')"
+ make DESTDIR="${pkgdir}" SBINDIR=/usr/bin SHLIBDIR=/usr/lib install
+ make DESTDIR="${pkgdir}" PYTHON=/usr/bin/python3 SBINDIR=/usr/bin SHLIBDIR=/usr/lib install-pywrap
+ make DESTDIR="${pkgdir}" RUBY=/usr/bin/ruby SBINDIR=/usr/bin SHLIBDIR=/usr/lib install-rubywrap
+ /usr/bin/python3 -m compileall "${pkgdir}/$(/usr/bin/python3 -c 'from distutils.sysconfig import *; print(get_python_lib(plat_specific=1))')"
install -Dm 0644 "${srcdir}"/libselinux.tmpfiles.d "${pkgdir}"/usr/lib/tmpfiles.d/libselinux.conf