summaryrefslogtreecommitdiff
path: root/community/0ad/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/0ad/PKGBUILD')
-rw-r--r--community/0ad/PKGBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/community/0ad/PKGBUILD b/community/0ad/PKGBUILD
index a510a3e0f..406461c25 100644
--- a/community/0ad/PKGBUILD
+++ b/community/0ad/PKGBUILD
@@ -1,21 +1,28 @@
-# $Id: PKGBUILD 105861 2014-02-16 16:38:12Z bpiotrowski $
+# $Id: PKGBUILD 105901 2014-02-18 12:42:08Z bpiotrowski $
# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
# Contributor: t3ddy <t3ddy1988 "at" gmail {dot} com>
# Contributor: Adrián Chaves Fernández (Gallaecio) <adriyetichaves@gmail.com>
pkgname=0ad
pkgver=a15
_pkgver=0.0.15-alpha
-pkgrel=3
+pkgrel=4
pkgdesc="Cross-platform, 3D and historically-based real-time strategy game"
arch=('i686' 'x86_64')
url="http://play0ad.com/"
license=('GPL2' 'CCPL')
depends=('binutils' 'boost-libs' 'curl' 'enet' 'libogg' 'libpng' 'libvorbis'
'libxml2' 'openal' 'sdl' 'wxgtk2.8' 'zlib' 'libgl' '0ad-data' 'glu'
- 'gloox' 'miniupnpc' 'libsm')
-makedepends=('boost' 'cmake' 'mesa' 'zip' 'python2')
-source=("http://releases.wildfiregames.com/$pkgname-$_pkgver-unix-build.tar.xz")
-md5sums=('a651d81eb9b31da01e376ddaa597e954')
+ 'gloox' 'miniupnpc')
+makedepends=('boost' 'cmake' 'mesa' 'zip' 'python2' 'libsm')
+source=("http://releases.wildfiregames.com/$pkgname-$_pkgver-unix-build.tar.xz"
+ "miniupnpc-1.9.patch")
+md5sums=('a651d81eb9b31da01e376ddaa597e954'
+ 'f3d27da4944d42fcf6b4153e54dc4600')
+
+prepare() {
+ cd "$srcdir/$pkgname-$_pkgver"
+ patch -p1 -i ../miniupnpc-1.9.patch
+}
build() {
cd "$srcdir/$pkgname-$_pkgver/build/workspaces"
@@ -25,6 +32,7 @@ build() {
export WX_CONFIG=/usr/bin/wx-config-2.8
./update-workspaces.sh \
--with-system-enet \
+ --with-system-miniupnpc \
--bindir=/usr/bin \
--libdir=/usr/lib/0ad \
--datadir=/usr/share/${pkgname}/data