summaryrefslogtreecommitdiff
path: root/community/go/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/go/PKGBUILD')
-rw-r--r--community/go/PKGBUILD23
1 files changed, 16 insertions, 7 deletions
diff --git a/community/go/PKGBUILD b/community/go/PKGBUILD
index d3bbcd4c0..56e9c03db 100644
--- a/community/go/PKGBUILD
+++ b/community/go/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 104859 2014-01-27 16:24:41Z arodseth $
+# $Id: PKGBUILD 105906 2014-02-18 23:59:49Z arodseth $
# Maintainer: Vesa Kaihlavirta <vegai@iki.fi>
# Maintainer: Alexander Rødseth <rodseth@gmail.com>
# Contributor: Rémy Oudompheng <remy@archlinux.org>
@@ -10,7 +10,7 @@
pkgname=go
pkgver=1.2
-pkgrel=2
+pkgrel=3
epoch=2
pkgdesc='Compiler and tools for the Go programming language from Google'
arch=('x86_64' 'i686')
@@ -19,16 +19,22 @@ license=('custom')
depends=('perl' 'gawk')
makedepends=('inetutils')
options=('!strip' 'staticlibs')
-optdepends=('liteide: IDE for editing and building projects written in Go')
+optdepends=('liteide: IDE for editing and building projects written in Go'
+ 'mercurial: Version control system written in Python'
+ 'git: Version control system written in C')
install="$pkgname.install"
backup=('usr/lib/go/bin')
if [ "$CARCH" == 'x86_64' ]; then
- source=("http://go.googlecode.com/files/${pkgname}$pkgver.linux-amd64.tar.gz")
- sha256sums=('1252ca0aa0a96d53c0592fbc4ea9c9ff5c6b588169c92e08d06da9d89d9d91f2')
+ source=("http://go.googlecode.com/files/${pkgname}$pkgver.linux-amd64.tar.gz"
+ 'go.sh')
+ sha256sums=('1252ca0aa0a96d53c0592fbc4ea9c9ff5c6b588169c92e08d06da9d89d9d91f2'
+ 'b6209904c88bde96efcac846c267e308e4dc39c8a45f2690204c2175de4b9b0a')
else
- source=("http://go.googlecode.com/files/${pkgname}$pkgver.linux-386.tar.gz")
- sha256sums=('3f51aacc7af60c520fe1071f3cb1d9ceee5db0e8fdfb7168a73e12fd7603e651')
+ source=("http://go.googlecode.com/files/${pkgname}$pkgver.linux-386.tar.gz"
+ 'go.sh')
+ sha256sums=('3f51aacc7af60c520fe1071f3cb1d9ceee5db0e8fdfb7168a73e12fd7603e651'
+ 'b6209904c88bde96efcac846c267e308e4dc39c8a45f2690204c2175de4b9b0a')
fi
build() {
@@ -129,6 +135,9 @@ package() {
install -Dm644 src/pkg/runtime/cgocall.h \
"$pkgdir/usr/lib/go/src/pkg/runtime/cgocall.h"
+ # In order to make godoc work, see FS#38597
+ install -Dm755 "$srcdir/$pkgname.sh" "$pkgdir/etc/profile.d/$pkgname.sh"
+
# This is to make go get code.google.com/p/go-tour/gotour and
# then running the gotour executable work out of the box.
ln -sf /usr/bin "$pkgdir/usr/lib/go/bin"