summaryrefslogtreecommitdiff
path: root/community/go/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/go/PKGBUILD')
-rw-r--r--community/go/PKGBUILD26
1 files changed, 9 insertions, 17 deletions
diff --git a/community/go/PKGBUILD b/community/go/PKGBUILD
index 52f9e77a8..d3bbcd4c0 100644
--- a/community/go/PKGBUILD
+++ b/community/go/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 101866 2013-12-02 13:37:29Z arodseth $
+# $Id: PKGBUILD 104859 2014-01-27 16:24:41Z arodseth $
# Maintainer: Vesa Kaihlavirta <vegai@iki.fi>
# Maintainer: Alexander Rødseth <rodseth@gmail.com>
# Contributor: Rémy Oudompheng <remy@archlinux.org>
@@ -10,7 +10,7 @@
pkgname=go
pkgver=1.2
-pkgrel=1
+pkgrel=2
epoch=2
pkgdesc='Compiler and tools for the Go programming language from Google'
arch=('x86_64' 'i686')
@@ -24,15 +24,11 @@ install="$pkgname.install"
backup=('usr/lib/go/bin')
if [ "$CARCH" == 'x86_64' ]; then
- source=("http://go.googlecode.com/files/${pkgname}$pkgver.linux-amd64.tar.gz"
- "$pkgname.sh")
- sha256sums=('1252ca0aa0a96d53c0592fbc4ea9c9ff5c6b588169c92e08d06da9d89d9d91f2'
- 'b6209904c88bde96efcac846c267e308e4dc39c8a45f2690204c2175de4b9b0a')
+ source=("http://go.googlecode.com/files/${pkgname}$pkgver.linux-amd64.tar.gz")
+ sha256sums=('1252ca0aa0a96d53c0592fbc4ea9c9ff5c6b588169c92e08d06da9d89d9d91f2')
else
- source=("http://go.googlecode.com/files/${pkgname}$pkgver.linux-386.tar.gz"
- "$pkgname.sh")
- sha256sums=('3f51aacc7af60c520fe1071f3cb1d9ceee5db0e8fdfb7168a73e12fd7603e651'
- 'b6209904c88bde96efcac846c267e308e4dc39c8a45f2690204c2175de4b9b0a')
+ source=("http://go.googlecode.com/files/${pkgname}$pkgver.linux-386.tar.gz")
+ sha256sums=('3f51aacc7af60c520fe1071f3cb1d9ceee5db0e8fdfb7168a73e12fd7603e651')
fi
build() {
@@ -41,10 +37,9 @@ build() {
export GOROOT_FINAL=/usr/lib/go
#
- # Arch Linux doesn't support SSE2 for i686.
- #
- # Use "go-sse2" from AUR if you have am i686 CPU that supports SSE2.
- # It is highly likely that it does, and the SSE2 version is _a lot_ faster.
+ # Arch Linux doesn't support SSE2 for i686 (to support older CPUs)
+ # The SSE2 version is _a lot_ faster for i686.
+ # This line disables it.
#
export GO386=387
@@ -134,9 +129,6 @@ package() {
install -Dm644 src/pkg/runtime/cgocall.h \
"$pkgdir/usr/lib/go/src/pkg/runtime/cgocall.h"
- # For packages that source /etc/profile.d/go.sh
- install -Dm755 "$srcdir/$pkgname.sh" "$pkgdir/etc/profile.d/$pkgname.sh"
-
# This is to make go get code.google.com/p/go-tour/gotour and
# then running the gotour executable work out of the box.
ln -sf /usr/bin "$pkgdir/usr/lib/go/bin"