summaryrefslogtreecommitdiff
path: root/community/plan9port/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/plan9port/PKGBUILD')
-rw-r--r--community/plan9port/PKGBUILD27
1 files changed, 17 insertions, 10 deletions
diff --git a/community/plan9port/PKGBUILD b/community/plan9port/PKGBUILD
index cc69553ba..4aa216d58 100644
--- a/community/plan9port/PKGBUILD
+++ b/community/plan9port/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 104876 2014-01-27 23:51:46Z arodseth $
+# $Id: PKGBUILD 105934 2014-02-19 12:29:36Z arodseth $
# Maintainer: Alexander Rødseth <rodseth@gmail.com>
# Contributor: phrakture <aaronmgriffin--gmail--com>
# Contributor: Fazlul Shahriar
@@ -6,7 +6,7 @@
pkgname=plan9port
pkgver=20131024
-pkgrel=3
+pkgrel=4
pkgdesc='Port of many programs from Plan 9 to Unix-like operating systems'
arch=('x86_64' 'i686')
url='http://swtch.com/plan9port/'
@@ -19,14 +19,16 @@ options=('!zipman' 'staticlibs')
source=("http://$pkgname.googlecode.com/files/$pkgname-$pkgver.tgz"
'plan9.sh')
sha256sums=('5cba7856bdb35a96a923120e61d320d424fee1a6f09b7af3e87eb7814a747d4f'
- 'c216efa3455ba0b22b1723ae62e4c1e21b3a776a760d8fcedb902ff994b701c1')
+ '8768c080a8ceb0a52a3f866bd8ffc4b26f9deb97c6877ceea78ec0b316325a6b')
package() {
cd "$pkgname"
- # TODO: Find a way to install in a better directory than /usr/local/plan9
+ # Try the gentoo way for fixing hardcoded paths
+ PLAN9=/usr/lib/plan9
+ grep --null -l -r '/usr/local/plan9' | xargs --null sed -i "s!/usr/local/plan9!${PLAN9}!g"
- d=usr/local
+ d=usr/lib
./INSTALL -b
install -Dm755 ../plan9.sh "$pkgdir/etc/profile.d/plan9.sh"
@@ -44,11 +46,11 @@ package() {
rm -f config install.log install.sum install.txt configure Makefile INSTALL \
LICENSE
- # Fix hardcoded paths
- for f in `grep -H -r "$pkgdir$d/$pkgname" | cut -d: -f1`; do
- echo -n "\t$f"
- [ -e "$f" ] && sed -i "s:$pkgdir$d/$pkgname:$d/$pkgname:" "$f" || true
- done
+ # The old method for fixing hardcoded paths
+ #for f in `grep -H -r "$pkgdir$d/$pkgname" | cut -d: -f1`; do
+ # echo -n "\t$f"
+ # [ -e "$f" ] && sed -i "s:$pkgdir$d/$pkgname:$d/$pkgname:" "$f" || true
+ #done
# Fix python scripts
find "$pkgdir" -name '*.py' -print0 |xargs -0 \
@@ -67,6 +69,11 @@ package() {
gunzip "$i"
fi
done
+
+ # Once more
+ #grep --null -l -r "$pkgdir/usr/local/plan9" | xargs --null sed -i "s!$pkgdir/usr/local/plan9!${PLAN9}!g"
+ grep --null -l -r "$pkgdir$PLAN9" | xargs --null sed -i "s!$pkgdir$PLAN9!${PLAN9}!g" || true
+ grep --null -l -r "/build/plan9port/pkg/plan9port/$PLAN9" | xargs --null sed -i "s!/build/plan9port/pkg/plan9port/$PLAN9!${PLAN9}!g" || true
}
# vim:set ts=2 sw=2 et: