summaryrefslogtreecommitdiff
path: root/community/xulrunner/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/xulrunner/PKGBUILD')
-rw-r--r--community/xulrunner/PKGBUILD23
1 files changed, 10 insertions, 13 deletions
diff --git a/community/xulrunner/PKGBUILD b/community/xulrunner/PKGBUILD
index a636fe5cf..8fe4e064a 100644
--- a/community/xulrunner/PKGBUILD
+++ b/community/xulrunner/PKGBUILD
@@ -1,29 +1,27 @@
-# $Id: PKGBUILD 103367 2014-01-04 06:59:57Z cbehan $
+# $Id: PKGBUILD 105483 2014-02-09 04:20:46Z cbehan $
# Maintainer: Connor Behan <connor.behan@gmail.com>
# Contributor: Jan de Groot <jgc@archlinux.org>
# Contributor: Alexander Baldeck <alexander@archlinux.org>
pkgname=xulrunner
-pkgver=25.0
+pkgver=27.0
pkgrel=1
pkgdesc="Mozilla Runtime Environment"
arch=('i686' 'x86_64')
license=('MPL' 'GPL' 'LGPL')
-depends=('gtk2' 'mozilla-common' 'nss>=3.15' 'libxt' 'hunspell' 'startup-notification' 'mime-types' 'dbus-glib' 'alsa-lib' 'libevent' 'libvpx' 'python2')
-makedepends=('zip' 'unzip' 'pkg-config' 'diffutils' 'yasm' 'mesa' 'autoconf2.13' 'gstreamer0.10-base>=0.10.25')
+depends=('gtk2' 'mozilla-common' 'nss' 'libxt' 'hunspell' 'startup-notification' 'mime-types' 'dbus-glib' 'alsa-lib' 'libevent' 'libvpx' 'python2')
+makedepends=('zip' 'unzip' 'pkg-config' 'diffutils' 'yasm' 'mesa' 'autoconf2.13' 'gstreamer0.10-base')
url="http://wiki.mozilla.org/XUL:Xul_Runner"
source=(ftp://ftp.mozilla.org/pub/mozilla.org/xulrunner/releases/$pkgver/source/xulrunner-$pkgver.source.tar.bz2
mozconfig
mozilla-pkgconfig.patch
- shared-libs.patch
- freetype-headers.patch)
-options=('!emptydirs' 'staticlibs')
+ shared-libs.patch)
+options=('!emptydirs' '!makeflags' 'staticlibs')
replaces=('xulrunner-oss')
-sha256sums=('796614f7a7a02ae4bceb5d1f2dce2de5096f9e390e91ec09fa5a40bcdff45cb1'
- 'b5e66890e991b194d9a6d2179bccd5ac0015d4aab0a8411c55c6ecfd06576c24'
+sha256sums=('4f6125c053e12c4ac3317b075e289b10ce470dd90ed6fc43c4572bf1acc64981'
+ '8455f7bc00e8ad6e69bba43171083c778420a8b1c566347ed5381ae9cf98191a'
'23485d937035648add27a7657f6934dc5b295e886cdb0506eebd02a43d07f269'
- 'e2b4a00d14f4ba69c62b3f9ef9908263fbab179ba8004197cbc67edbd916fdf1'
- 'b62975b25fa3a0dc3e57e32c2b980daf2ee2497eff1d9661595b8e8bafbaa5f8')
+ 'e2b4a00d14f4ba69c62b3f9ef9908263fbab179ba8004197cbc67edbd916fdf1')
prepare() {
cd "$srcdir/mozilla-release"
@@ -32,7 +30,6 @@ prepare() {
#fix libdir/sdkdir - fedora
patch -Np1 -i ../mozilla-pkgconfig.patch
patch -Np1 -i ../shared-libs.patch
- patch -Np1 -i ../freetype-headers.patch
# WebRTC build tries to execute "python" and expects Python 2
# Workaround taken from chromium PKGBUILD
@@ -51,7 +48,7 @@ build() {
export LDFLAGS="$LDFALGS -Wl,-rpath,/usr/lib/xulrunner-$pkgver"
export PYTHON="/usr/bin/python2"
- make -j1 -f client.mk build MOZ_MAKE_FLAGS="$MAKEFLAGS"
+ make -j1 -f client.mk build
}
package() {