summaryrefslogtreecommitdiff
path: root/core/gcc/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/gcc/PKGBUILD')
-rw-r--r--core/gcc/PKGBUILD55
1 files changed, 26 insertions, 29 deletions
diff --git a/core/gcc/PKGBUILD b/core/gcc/PKGBUILD
index d4909f66d..3b186436b 100644
--- a/core/gcc/PKGBUILD
+++ b/core/gcc/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 205614 2014-02-10 03:07:49Z allan $
+# $Id$
# Maintainer: Allan McRae <allan@archlinux.org>
# toolchain build order: linux-api-headers->glibc->binutils->gcc->binutils->glibc
@@ -15,10 +15,10 @@ if [ "${CARCH}" != "mips64el" ]; then
else
pkgname=('gcc' 'gcc-libs' 'gcc-fortran' 'gcc-objc')
fi
-pkgver=4.8.2
-_pkgver=4.8
-pkgrel=8
-_snapshot=4.8-20140206
+pkgver=4.9.0
+_pkgver=4.9
+pkgrel=3
+_snapshot=4.9-20140521
pkgdesc="The GNU Compiler Collection"
arch=('i686' 'x86_64' 'mips64el')
license=('GPL' 'LGPL' 'FDL' 'custom')
@@ -29,11 +29,9 @@ checkdepends=('dejagnu' 'inetutils')
options=('!emptydirs')
source=(#ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2
ftp://gcc.gnu.org/pub/gcc/snapshots/${_snapshot}/gcc-${_snapshot}.tar.bz2
- gcc-4.8-filename-output.patch
- gcc-4.8-lambda-ICE.patch)
-md5sums=('9d35549404a2326540fb88301ebd1977'
- '40cb437805e2f7a006aa0d0c3098ab0f'
- '6eb6e080dbf7bc6825f53a0aaa6c4ef9')
+ gcc-4.8-filename-output.patch)
+md5sums=('cd3cbe93ebc7207bf65d30e3c9a74a26'
+ '40cb437805e2f7a006aa0d0c3098ab0f')
if [ -n "${_snapshot}" ]; then
_basedir=gcc-${_snapshot}
@@ -60,13 +58,6 @@ prepare() {
# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=57653
patch -p0 -i ${srcdir}/gcc-4.8-filename-output.patch
-
- # http://gcc.gnu.org/bugzilla//show_bug.cgi?id=56710 - commit 3d1f8279
- patch -p1 -i ${srcdir}/gcc-4.8-lambda-ICE.patch
-
- # installing libiberty headers is broken
- # http://gcc.gnu.org/bugzilla/show_bug.cgi?id=56780#c6
- sed -i 's#@target_header_dir@#libiberty#' libiberty/Makefile.in
mkdir ${srcdir}/gcc-build
}
@@ -146,17 +137,18 @@ package_gcc-libs()
make -C $CHOST/libgcc DESTDIR=${pkgdir} install-shared
rm -f ${pkgdir}/${_libdir}/libgcc_eh.a
- for lib in libmudflap \
+ for lib in libatomic \
+ libcilkrts \
+ libgfortran \
libgomp \
libitm \
- libatomic \
- libstdc++-v3/src \
libquadmath \
- libgfortran \
- libsanitizer/asan; do
- # Skip libitm and asan on mips64el
+ libsanitizer/{a,l,ub}san \
+ libstdc++-v3/src \
+ libvtv; do
+ # Skip libcilkrts, libitm, asan, lsan, ubsan and libvtv on mips64el
test "$CARCH" = "mips64el" &&
- echo "libitm libsanitizer/asan" | grep -q "$lib" &&
+ echo "libcilkrts libitm libsanitizer/asan libsanitizer/lsan libsanitizer/ubsan libvtv" | grep -q "$lib" &&
continue
make -C $CHOST/$lib DESTDIR=${pkgdir} install-toolexeclibLTLIBRARIES
done
@@ -179,9 +171,6 @@ package_gcc-libs()
# Install Runtime Library Exception
install -Dm644 ${srcdir}/${_basedir}/COPYING.RUNTIME \
${pkgdir}/usr/share/licenses/gcc-libs/RUNTIME.LIBRARY.EXCEPTION
-
- # for some reason this end up both in gcc and gcc-libs
- rm -f ${pkgdir}/usr/lib/libstdc++.{l,}a
}
package_gcc()
@@ -217,18 +206,26 @@ package_gcc()
make -C gcc DESTDIR=${pkgdir} install-mkheaders
make -C lto-plugin DESTDIR=${pkgdir} install
+# itm not available in mips
+ test "$CARCH" != "mips64el" &&
+ make -C $CHOST/libcilkrts DESTDIR=${pkgdir} install-nodist_toolexeclibHEADERS \
+ install-nodist_cilkincludeHEADERS
make -C $CHOST/libgomp DESTDIR=${pkgdir} install-nodist_toolexeclibHEADERS \
install-nodist_libsubincludeHEADERS
# itm not available in mips
test "$CARCH" != "mips64el" &&
make -C $CHOST/libitm DESTDIR=${pkgdir} install-nodist_toolexeclibHEADERS
- make -C $CHOST/libmudflap DESTDIR=${pkgdir} install-nobase_libsubincludeHEADERS
make -C $CHOST/libquadmath DESTDIR=${pkgdir} install-nodist_libsubincludeHEADERS
+# libsanitizer not available in mips
+ test "$CARCH" != "mips64el" &&
+ make -C $CHOST/libsanitizer DESTDIR=${pkgdir} install-nodist_toolexeclibHEADERS
# asan not available in mips
test "$CARCH" != "mips64el" &&
make -C $CHOST/libsanitizer/asan DESTDIR=${pkgdir} install-nodist_toolexeclibHEADERS
make -C libiberty DESTDIR=${pkgdir} install
+ # install PIC version of libiberty
+ install -m644 ${srcdir}/gcc-build/libiberty/pic/libiberty.a ${pkgdir}/usr/lib
make -C gcc DESTDIR=${pkgdir} install-man install-info
rm -f ${pkgdir}/usr/share/man/man1/{gccgo,gfortran}.1
@@ -237,7 +234,7 @@ package_gcc()
make -C libcpp DESTDIR=${pkgdir} install
make -C gcc DESTDIR=${pkgdir} install-po
- # many packages expect this symlinks
+ # many packages expect this symlink
ln -s gcc ${pkgdir}/usr/bin/cc
# POSIX conformance launcher scripts for c89 and c99