summaryrefslogtreecommitdiff
path: root/core/libsasl/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/libsasl/PKGBUILD')
-rw-r--r--core/libsasl/PKGBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/core/libsasl/PKGBUILD b/core/libsasl/PKGBUILD
index e8cd341aa..beb08d3c7 100644
--- a/core/libsasl/PKGBUILD
+++ b/core/libsasl/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 197827 2013-10-30 11:05:21Z allan $
+# $Id: PKGBUILD 205603 2014-02-09 10:29:30Z andyrtr $
# Maintainer: Jan de Groot <jgc@archlinux.org>
# This package spans multiple repositories.
@@ -8,13 +8,13 @@
#pkgname=('cyrus-sasl' 'cyrus-sasl-gssapi' 'cyrus-sasl-ldap' 'cyrus-sasl-sql')
pkgname=libsasl
pkgver=2.1.26
-pkgrel=6
+pkgrel=7
pkgdesc="Cyrus Simple Authentication Service Layer (SASL) library"
arch=('i686' 'x86_64')
url="http://cyrusimap.web.cmu.edu/"
license=('custom')
options=('!makeflags')
-makedepends=('postgresql-libs' 'libmariadbclient' 'libldap' 'krb5' 'openssl' 'sqlite2')
+makedepends=('postgresql-libs' 'libmariadbclient' 'libldap' 'krb5' 'openssl' 'sqlite')
source=(ftp://ftp.cyrusimap.org/cyrus-sasl/cyrus-sasl-${pkgver}.tar.gz
cyrus-sasl-2.1.22-qa.patch
cyrus-sasl-2.1.26-size_t.patch
@@ -26,7 +26,8 @@ source=(ftp://ftp.cyrusimap.org/cyrus-sasl/cyrus-sasl-${pkgver}.tar.gz
saslauthd.service
saslauthd.conf.d
tmpfiles.conf
- CVE-2013-4122.patch)
+ CVE-2013-4122.patch
+ cyrus-sasl-sql.patch)
md5sums=('a7f4e5e559a0e37b3ffc438c9456e425'
'79b8a5e8689989e2afd4b7bda595a7b1'
'f45aa8c42b32e0569ab3d14a83485b37'
@@ -38,7 +39,8 @@ md5sums=('a7f4e5e559a0e37b3ffc438c9456e425'
'3499dcd610ad1ad58e0faffde2aa7a23'
'49219af5641150edec288a3fdb65e7c1'
'45bb0192d2f188066240b9a66ee6365f'
- 'c5f0ec88c584a75c14d7f402eaeed7ef')
+ 'c5f0ec88c584a75c14d7f402eaeed7ef'
+ '82c0f66fdc5c1145eb48ea9116c27931')
prepare() {
cd cyrus-sasl-$pkgver
@@ -50,6 +52,7 @@ prepare() {
patch -Np1 -i ../0026_drop_krb5support_dependency.patch
patch -Np1 -i ../0030-dont_use_la_files_for_opening_plugins.patch
patch -Np1 -i ../CVE-2013-4122.patch
+ patch -Np0 -i ../cyrus-sasl-sql.patch
sed 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' -i configure.in
}
@@ -100,11 +103,15 @@ build() {
--enable-ntlm \
--disable-passdss \
--enable-sql \
+ --with-mysql \
+ --with-pgsql=/usr/lib \
+ --with-sqlite3=/usr/lib \
--enable-ldapdb \
--disable-macos-framework \
--with-pam \
--with-saslauthd=/var/run/saslauthd \
--with-ldap \
+ --with-dblib=gdbm \
--with-configdir=/etc/sasl2:/etc/sasl:/usr/lib/sasl2 \
--sysconfdir=/etc \
--with-devrandom=/dev/urandom
@@ -174,7 +181,7 @@ package_cyrus-sasl-ldap() {
package_cyrus-sasl-sql() {
pkgdesc="SQL auxprop module for Cyrus SASL"
- depends=("libsasl=${pkgver}" 'postgresql-libs' 'libmariadbclient' 'sqlite2')
+ depends=("libsasl=${pkgver}" 'postgresql-libs' 'libmariadbclient' 'sqlite')
replaces=('cyrus-sasl-plugins')
cd cyrus-sasl-$pkgver/plugins