summaryrefslogtreecommitdiff
path: root/cross/cross-mipsel-unknown-linux-gnu-gcc/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'cross/cross-mipsel-unknown-linux-gnu-gcc/PKGBUILD')
-rw-r--r--cross/cross-mipsel-unknown-linux-gnu-gcc/PKGBUILD54
1 files changed, 0 insertions, 54 deletions
diff --git a/cross/cross-mipsel-unknown-linux-gnu-gcc/PKGBUILD b/cross/cross-mipsel-unknown-linux-gnu-gcc/PKGBUILD
deleted file mode 100644
index f2d9b2e8b..000000000
--- a/cross/cross-mipsel-unknown-linux-gnu-gcc/PKGBUILD
+++ /dev/null
@@ -1,54 +0,0 @@
-# Contributor: Vojtech Horky <vojta . horky at-symbol seznam . cz>
-pkgname=cross-mipsel-linux-gnu-gcc
-_pkgname=gcc
-_target="mipsel-linux-gnu"
-pkgver=4.6.2
-pkgrel=1
-pkgdesc="The GNU Compiler Collection for the MIPS architecture"
-url="http://www.gnu.org/software/binutils/"
-arch=('i686' 'x86_64')
-license=('GPL')
-depends=('libmpc' 'sh' "cross-${_target}-binutils" 'cloog' 'ppl')
-options=('!ccache' '!distcc' '!emptydirs' '!libtool' '!strip')
-source=("ftp://ftp.gnu.org/gnu/gcc/gcc-${pkgver}/${_pkgname}-core-${pkgver}.tar.bz2")
-md5sums=('b1957f3209080b2f55bc3756d3a62b7c')
-_sysroot="/usr/lib/cross-${_target}"
-
-build() {
- cd ${srcdir}/${_pkgname}-${pkgver}
-
- ./configure \
- "--prefix=${_sysroot}" \
- "--bindir=/usr/bin" "--program-prefix=${_target}-" \
- "--with-sysroot=${_sysroot}" \
- "--target=${_target}" "--build=$CHOST" "--host=$CHOST" \
- --with-gnu-as --with-gnu-ld \
- --disable-nls --disable-threads \
- --enable-languages=c,c++ \
- --disable-multilib --disable-libgcj \
- --without-headers --disable-shared
-
- make all-gcc "inhibit_libc=true"
-}
-
-package() {
- cd ${srcdir}/${_pkgname}-${pkgver}
-
- make DESTDIR=${pkgdir} install-gcc
-
- msg "Removing duplicit files..."
- # remove these files as they are already in the system
- # (with native gcc)
- rm -Rf ${pkgdir}${_sysroot}/{man,info}
- # remove conflicting binaries
- find ${pkgdir}/usr/bin/ -type f -not -name "${_target}-*" -delete
-
- msg "Creating out-of-path executables..."
- # symlink executables to single directory with no-arch-prefix name
- mkdir -p ${pkgdir}/usr/bin/cross/${_target}/;
- cd ${pkgdir}/usr/bin/cross/${_target}/;
- for bin in ${pkgdir}/usr/bin/${_target}-*; do
- bbin=`basename "$bin"`;
- ln -s "/usr/bin/${bbin}" `echo "$bbin" | sed "s#^${_target}-##"`;
- done
-}