summaryrefslogtreecommitdiff
path: root/extra/geoclue2/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/geoclue2/PKGBUILD')
-rw-r--r--extra/geoclue2/PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/extra/geoclue2/PKGBUILD b/extra/geoclue2/PKGBUILD
index 8950df832..1c18126d4 100644
--- a/extra/geoclue2/PKGBUILD
+++ b/extra/geoclue2/PKGBUILD
@@ -1,20 +1,26 @@
-# $Id: PKGBUILD 197983 2013-10-30 12:04:51Z allan $
+# $Id: PKGBUILD 206065 2014-02-16 16:10:59Z heftig $
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Contributor: György Balló <ballogy@freestart.hu>
pkgname=geoclue2
-pkgver=1.99.4
+pkgver=2.0.0
pkgrel=1
-pkgdesc="Modular geoinformation service built on the D-Bus messaging system."
+pkgdesc="Modular geoinformation service built on the D-Bus messaging system"
arch=(i686 x86_64)
url="http://geoclue.freedesktop.org/"
license=(LGPL)
depends=(libsoup json-glib)
makedepends=(intltool geoip)
optdepends=('geoip: geoip-lookup server binary')
-install=geoclue.install
-source=(http://freedesktop.org/software/geoclue/releases/1.99/geoclue-$pkgver.tar.xz)
-md5sums=('b991f4a409b492996a38627ee18fa76e')
+source=(http://freedesktop.org/software/geoclue/releases/2.0/geoclue-$pkgver.tar.xz
+ https.patch)
+md5sums=('401ff99d530b177c62afacef0a33efd9'
+ '20da579a0f1f6476a9c2ba9adebec32c')
+
+prepare() {
+ cd geoclue-$pkgver
+ patch -Np1 -i ../https.patch
+}
build() {
cd geoclue-$pkgver