summaryrefslogtreecommitdiff
path: root/extra/mono/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/mono/PKGBUILD')
-rw-r--r--extra/mono/PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/extra/mono/PKGBUILD b/extra/mono/PKGBUILD
index 6e2ba74c1..ab930d5c2 100644
--- a/extra/mono/PKGBUILD
+++ b/extra/mono/PKGBUILD
@@ -1,34 +1,34 @@
-# $Id: PKGBUILD 198325 2013-10-30 14:10:51Z allan $
+# $Id: PKGBUILD 205609 2014-02-09 10:29:41Z andyrtr $
# Maintainer: Daniel Isenmann <daniel@archlinux.org>
# Contributor: Brice Carpentier <brice@dlfp.org>
pkgname=mono
pkgver=3.2.3
-pkgrel=1
+pkgrel=2
pkgdesc="Free implementation of the .NET platform including runtime and compiler"
arch=(i686 x86_64)
-license=('GPL' 'LGPL2' 'MPL' 'custom:MITX11')
+license=('GPL' 'LGPL2.1' 'MPL' 'custom:MITX11')
url="http://www.mono-project.com/"
-depends=('zlib' 'libgdiplus>=2.10' 'sh')
-makedepends=('pkgconfig')
+depends=('zlib' 'libgdiplus>=2.10' 'sh' 'python')
options=('!makeflags')
provides=('monodoc')
conflicts=('monodoc')
-install=mono.install
source=(http://download.mono-project.com/sources/mono/${pkgname}-${pkgver}.tar.bz2
mono.binfmt.d
- mono.install
- sgen_fix.patch)
+ sgen_fix.patch)
md5sums=('a66c6309fad071e21f77f4c6b67a0f10'
'b9ef8a65fea497acf176cca16c1e2402'
- 'ca1108e9638b01c26453ee663592a4e5'
'8a700b94bff7a913f920e95890d2fb4c')
build() {
cd "${srcdir}"/${pkgname}-${pkgver}
patch -p1 < ../sgen_fix.patch
# build mono
- ./configure --prefix=/usr --sysconfdir=/etc --bindir=/usr/bin --sbindir=/usr/bin
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --bindir=/usr/bin \
+ --sbindir=/usr/bin \
+ --disable-static
make
# build jay
@@ -41,9 +41,9 @@ package() {
make DESTDIR="${pkgdir}" install
# install jay
- cd "${srcdir}"/${pkgname}-${pkgver}/mcs/jay
+ pushd "${srcdir}"/${pkgname}-${pkgver}/mcs/jay
make DESTDIR="${pkgdir}" prefix=/usr INSTALL=../../install-sh install
- cd "${srcdir}"/${pkgname}-${pkgver}
+ popd
# install binfmt conf file and pathes
install -D -m644 "${srcdir}"/mono.binfmt.d "${pkgdir}"/usr/lib/binfmt.d/mono.conf