summaryrefslogtreecommitdiff
path: root/libre/icecat/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/icecat/PKGBUILD')
-rw-r--r--libre/icecat/PKGBUILD188
1 files changed, 0 insertions, 188 deletions
diff --git a/libre/icecat/PKGBUILD b/libre/icecat/PKGBUILD
deleted file mode 100644
index 17a9da2b9..000000000
--- a/libre/icecat/PKGBUILD
+++ /dev/null
@@ -1,188 +0,0 @@
-# Maintainer (Parabola): André Silva <emulatorman@parabola.nu>
-# Maintainer (Parabola): Márcio Silva <coadde@lavabit.com>
-# Contributor (ConnochaetOS): Henry Jensen <hjensen@connochaetos.org>
-# Contributor (Parabola): Luke Shumaker <lukeshu@sbcglobal.net>
-# Contributor: Figue <ffigue at gmail>
-# Contributor (Parabola): fauno <fauno@kiwwwi.com.ar>
-# Contributor (Parabola): vando <facundo@esdebian.org>
-# Contributor (Arch): Jakub Schmidtke <sjakub@gmail.com>
-# Thank you very much to the older contributors:
-# Contributor: evr <evanroman at gmail>
-# Contributor: Muhammad 'MJ' Jassim <UnbreakableMJ@gmail.com>
-
-_pgo=false
-
-pkgname=icecat
-pkgver=24.0
-pkgrel=5
-pkgdesc='GNU IceCat, the standalone web browser based on Mozilla Firefox.'
-arch=(i686 x86_64 mips64el)
-license=(MPL GPL LGPL)
-depends=(alsa-lib dbus-glib desktop-file-utils gtk2 hicolor-icon-theme hunspell libevent libnotify libvpx libxt mime-types mozilla-common mozilla-searchplugins nss sqlite startup-notification)
-makedepends=(autoconf2.13 diffutils gstreamer0.10-base imagemagick imake inetutils libidl2 libpulse librsvg libxslt mesa pkg-config python2 unzip zip)
-options=(!emptydirs !makeflags)
-if $_pgo; then
- makedepends+=(xorg-server-xvfb)
- options+=(!ccache)
-fi
-optdepends=('networkmanager: Location detection via available WiFi networks'
- 'gstreamer0.10-base-plugins: vorbis decoding, ogg demuxing'
- 'gstreamer0.10-good-plugins: webm and mp4 demuxing'
- 'gstreamer0.10-bad-libre-plugins: aac, vp8 and opus decoding'
- 'gstreamer0.10-ugly-plugins: h.264 and mp3 decoding'
- 'gstreamer0.10-ffmpeg: more decoders'
- 'libpulse: PulseAudio audio driver')
-url=http://www.gnu.org/software/gnuzilla/
-install=$pkgname.install
-source=(
- ftp://ftp.gnu.org/gnu/gnuzilla/${pkgver::2}/$pkgname-$pkgver.tar.gz
- mozconfig
- mozconfig.pgo
- libre.patch
- $pkgname.desktop
- $pkgname-safe.desktop
- $pkgname-install-dir.patch
- vendor.js
- icecat-20.0.1-fixed-loading-icon.png
-)
-
-md5sums=(
- 0d3fdcec3f5fde494dedb595387e8f21
- 71dce16848bc51503a154841ce99427b
- df08eaa1ac3bc6c2356be4fbf8ec8932
- 21b5014c55aa97983f833886e047f55c
- b41f82994fa056ffa5f8e6d99570e27a
- b30ba2b5562558d510fdd09d626d0faa
- 64826fcf48816b13090042eefddbaa58
- 1dfa11e781950a969205e83840e9741e
- 6e335a517c68488941340ee1c23f97b0
-)
-
-prepare() {
- mv $pkgname-$pkgver $srcdir/gnuzilla-build
- cd $srcdir/gnuzilla-build
-
- cp $srcdir/mozconfig .mozconfig # Load our build config, disable SafeSearch
-
- if $_pgo; then
- cat $srcdir/mozconfig.pgo >> .mozconfig
- fi
-
- patch -Np1 -i $srcdir/$pkgname-install-dir.patch # install to /usr/lib/$pkgname
-
- # Patch and remove anything that's left
- patch -Np1 -i $srcdir/libre.patch
- sed -i 's|Adobe Flash|SWF Player|g;
- ' browser/base/content/pageinfo/permissions.js \
- browser/base/content/browser-plugins.js
- sed -i '\|URL of the GeoLocation backend|d;
- \|geo[.]wifi[.]uri|d;
- ' browser/app/profile/firefox.js
-
- # Fix for use nspr, sqlite and nss external
- sed -i 's/\(MOZ_PKG_FATAL_WARNINGS =\).*/\1 0/' \
- browser/installer/Makefile.in
-
- # This is a bug, we should fix it
- if [ $CARCH = mips64el ]; then
- # Fix MIPS N32 support.
- sed -i 's/defined(_ABIO32)/(defined(_ABIO32) || defined(_ABIN32))/' \
- js/src/assembler/wtf/Platform.h
- # Disable JIT.
- sed -ri 's/#define ENABLE_(JIT|ASSEMBLER) 1/#define ENABLE_\1 0/' \
- js/src/assembler/wtf/Platform.h
- sed -ri 's/ENABLE_(JIT|ASSEMBLER)=1/ENABLE_\1=0/' js/src/Makefile.in
- echo 'ac_add_options --disable-methodjit' >> .mozconfig
- echo 'ac_add_options --disable-tracejit' >> .mozconfig
- echo 'ac_add_options --disable-jemalloc' >> .mozconfig
- fi
-
- # disable necko-wifi and wireless_tools in IceCat
- #echo 'ac_add_options --disable-necko-wifi' >> .mozconfig
-
- chmod +x build/unix/run-icecat.sh # fix bug for bad file permition
-
- # Fix PRE_RELEASE_SUFFIX
- sed -i '/^PRE_RELEASE_SUFFIX := ""/s/ ""//' \
- browser/base/Makefile.in
-
- mkdir "$srcdir/path"
-
- # WebRTC build tries to execute "python" and expects Python 2
- ln -s /usr/bin/python2 "$srcdir/path/python"
-
- # Use gold, as Mozilla can use some of its features, such as safe ICF
- #ln -s /usr/bin/ld.gold "$srcdir/path/ld"
-
- # configure script misdetects the preprocessor without an optimization level
- # https://bugs.archlinux.org/task/34644
- sed -i '/ac_cpp=/s/$CPPFLAGS/& -O2/' configure
-
- # Fix tab loading icon (flickers with libpng 1.6)
- # https://bugzilla.mozilla.org/show_bug.cgi?id=841734
- cp "$srcdir/icecat-20.0.1-fixed-loading-icon.png" \
- browser/themes/linux/tabbrowser/loading.png
-}
-
-build() {
- cd $srcdir/gnuzilla-build
-
- export PATH="$srcdir/path:$PATH"
- export LDFLAGS="$LDFLAGS -Wl,-rpath,/usr/lib/$pkgname"
- export PYTHON="/usr/bin/python2"
-
- if [[ $CARCH == i686 ]]; then
- # Work around memory address space exhaustion during linking on i686
- LDFLAGS+=' -Wl,--no-keep-memory'
- fi
-
- if $_pgo; then
- if [[ $CARCH != i686 ]]; then
- # Set up PGO
- export DISPLAY=:99
- Xvfb -nolisten tcp -extension GLX -screen 0 1280x1024x24 $DISPLAY &
-
- if ! make -f client.mk build MOZ_PGO=1; then
- kill $!
- return 1
- fi
-
- kill $! || true
- else
- make -f client.mk build
- fi
- else
- make -f client.mk build
- fi
-}
-
-package() {
- cd $srcdir/gnuzilla-build
- make -j1 -f client.mk DESTDIR=$pkgdir install
-
- install -Dm644 ../vendor.js "$pkgdir/usr/lib/$pkgname/browser/defaults/preferences/vendor.js"
-
- brandingdir=browser/branding/unofficial
- icondir=$pkgdir/usr/share/icons/hicolor
- for i in 16x16 32x32 48x48; do
- install -Dm644 $brandingdir/default${i/x*/}.png $icondir/$i/apps/$pkgname.png
- done
-
- for d in $pkgname $pkgname-safe; do
- install -Dm644 $srcdir/$d.desktop $pkgdir/usr/share/applications/$d.desktop
- done
-
- rm -rf $pkgdir/usr/lib/$pkgname/{dictionaries,hyphenation}
- ln -sf /usr/share/hunspell $pkgdir/usr/lib/$pkgname/dictionaries
- ln -sf /usr/share/hyphen $pkgdir/usr/lib/$pkgname/hyphenation
-
- rm -rf $pkgdir/usr/lib/$pkgname/browser/{searchplugins,plugins}
- ln -sf /usr/lib/mozilla/plugins $pkgdir/usr/lib/$pkgname/browser/plugins
- ln -sf /usr/lib/mozilla/searchplugins $pkgdir/usr/lib/$pkgname/browser/searchplugins
-
- # We don't want the development stuff
- rm -rf $pkgdir/usr/{include,lib/$pkgname-devel,share/idl}
-
- # Workaround for now: https://bugzilla.mozilla.org/show_bug.cgi?id=658850
- ln -sf $pkgname $pkgdir/usr/lib/$pkgname/$pkgname-bin
-}