summaryrefslogtreecommitdiff
path: root/libre/unzip-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/unzip-libre/PKGBUILD')
-rw-r--r--libre/unzip-libre/PKGBUILD57
1 files changed, 0 insertions, 57 deletions
diff --git a/libre/unzip-libre/PKGBUILD b/libre/unzip-libre/PKGBUILD
deleted file mode 100644
index 2c4ce4150..000000000
--- a/libre/unzip-libre/PKGBUILD
+++ /dev/null
@@ -1,57 +0,0 @@
-# $Id: PKGBUILD 150452 2012-02-17 23:21:23Z allan $
-# Maintainer:
-# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
-# Contributor: Robson Peixoto
-
-_pkgname=unzip
-pkgname=unzip-libre
-pkgver=6.0
-pkgrel=6
-pkgdesc="Unpacks .zip archives such as those made by PKZIP"
-arch=('i686' 'x86_64')
-url="http://www.info-zip.org/"
-license=('custom')
-depends=('bzip2' 'bash')
-provides=("${_pkgname}=${pkgver}")
-conflicts=("${_pkgname}")
-replaces=("${_pkgname}")
-mksource=('http://downloads.sourceforge.net/infozip/unzip60.tar.gz'
- 'match.patch')
-source=('https://repo.parabolagnulinux.org/other/$pkgname/unzip60-libre.tar.gz')
-mkmd5sums=('62b490407489521db863b523a7f86375'
- 'e6d9f0c204c2abe6a57dc5e1637d5140')
-md5sums=('bbe4b7f4d48b2f939b5e43fde0ac7762')
-
-mksource() {
- cd ${srcdir}/${_pkgname}${pkgver/./}
-
- # from http://bzr.trisquel.info/package-helpers/trunk/annotate/head%3A/helpers/natty/DATA/unzip/match.patch
- patch -Np0 -i ${srcdir}/match.patch
-}
-
-build() {
- cd ${srcdir}/${_pkgname}${pkgver/./}
-
- # set CFLAGS -- from Debian
- export CFLAGS="$CFLAGS -D_FILE_OFFSET_BITS=64 -DACORN_FTYPE_NFS \
- -DWILD_STOP_AT_DIR -DLARGE_FILE_SUPPORT -DUNICODE_SUPPORT \
- -DUNICODE_WCHAR -DUTF8_MAYBE_NATIVE -DNO_LCHMOD -DDATE_FORMAT=DF_YMD \
- -DUSE_BZIP2 -DNATIVE"
-
- sed -i "/MANDIR =/s#)/#)/share/#" unix/Makefile
-
- # make -- from Debian
- make -f unix/Makefile LOCAL_UNZIP="$CFLAGS" prefix=/usr LF2="" \
- D_USE_BZ2=-DUSE_BZIP2 L_BZ2=-lbz2 unzips
-}
-
-package(){
- cd ${srcdir}/${_pkgname}${pkgver/./}
-
- # install -- from Debian
- make -f unix/Makefile prefix=${pkgdir}/usr INSTALL_PROGRAM="install" install
-
- # install the license file
- install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/unzip/LICENSE
-}
-