summaryrefslogtreecommitdiff
path: root/libre/vim-colorsamplerpack-libre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'libre/vim-colorsamplerpack-libre/PKGBUILD')
-rw-r--r--libre/vim-colorsamplerpack-libre/PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/libre/vim-colorsamplerpack-libre/PKGBUILD b/libre/vim-colorsamplerpack-libre/PKGBUILD
new file mode 100644
index 000000000..6d7f800a0
--- /dev/null
+++ b/libre/vim-colorsamplerpack-libre/PKGBUILD
@@ -0,0 +1,44 @@
+# $Id: PKGBUILD 95528 2013-08-13 11:23:39Z svenstaro $
+# Contributor: Aaron Griffin <aaron@archlinux.org>
+# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Maintainer (Parabola): André Silva <emulatorman@parabola.nu>
+
+_pkgname=vim-colorsamplerpack
+pkgname=vim-colorsamplerpack-libre
+pkgver=2012.10.28
+pkgrel=3
+_scriptid=18915
+pkgdesc="Different colorschemes for vim, without nonfree colorschemes"
+arch=('any')
+url="http://www.vim.org/scripts/script.php?script_id=625"
+license=('GPL2' 'GPL3' 'custom')
+replaces=$_pkgname
+conflicts=$_pkgname
+provides=$_pkgname=$pkgver
+depends=('vim')
+makedepends=('unzip')
+groups=('vim-plugins')
+mksource=(ColorSamplerPack.zip::"http://www.vim.org/scripts/download_script.php?src_id=$_scriptid")
+source=("https://repo.parabolagnulinux.org/other/${pkgname}/ColorSamplerPack-libre.tar.xz"
+ 'LICENSE')
+mkmd5sums=('b0f1bd54b396e3d6032c01ef1fb421b6')
+md5sums=('73d62829a9ad2cde3f1d03a3fbe154ee'
+ '6db49cf0613715ff3b7c50072367981c')
+
+mksource() {
+ # Remove nonfree colorschemes
+ cd ${srcdir}
+ mv colors colors-tmp
+ install -d colors
+ install -m644 colors-tmp/{calmar256-light,cleanphp,dante,ekvoli,lettuce,marklar,martin_krischik,motus,railscasts,relaxedgreen,synic,tabula,vibrantink,vividchalk,xoria256,zenburn}.vim colors
+ rm -rv colors-tmp
+}
+
+package() {
+ cd ${srcdir}
+ installpath="${pkgdir}/usr/share/vim/vim74"
+ install -d $installpath/colors/
+ install -m644 colors/* $installpath/colors
+ install -D -m644 plugin/color_sample_pack.vim $installpath/plugin/themes.vim
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}