summaryrefslogtreecommitdiff
path: root/pcr/bup/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/bup/PKGBUILD')
-rw-r--r--pcr/bup/PKGBUILD35
1 files changed, 0 insertions, 35 deletions
diff --git a/pcr/bup/PKGBUILD b/pcr/bup/PKGBUILD
deleted file mode 100644
index d45d60961..000000000
--- a/pcr/bup/PKGBUILD
+++ /dev/null
@@ -1,35 +0,0 @@
-# Contributor: Bram Schoenmakers <me@bramschoenmakers.nl>
-# Contributor: henning mueller <henning@orgizm.net>
-# Maintainer : Parabola GNU / Linux-libre Aurélien Desbrières <aurelien@cwb.io>
-
-# If you'd like to have documentation, please set the variable below to 1.
-# This implies installing pandoc, which in turn depends on many Haskell packages.
-# Which you can build if you wish.
-_havedocs=0
-
-pkgname=bup
-pkgver=0.25rc1
-_pkgver=0.25-rc1
-pkgrel=2
-pkgdesc="Backup tool using git pack files."
-arch=('i686' 'x86_64')
-url="http://github.com/apenwarr/bup"
-license=('GPL')
-depends=('python2-fuse' 'par2cmdline' 'python' 'git')
-[ $_havedocs = 1 ] && makedepends=('haskell-pandoc')
-source=("https://github.com/apenwarr/${pkgname}/archive/${pkgname}-${_pkgver}.tar.gz")
-
-build() {
- cd "${srcdir}/${pkgname}-${pkgname}-${_pkgver}"
-
- find . -name \*.py | xargs sed -i 's:env python:env python2:'
- sed -i 's:PYTHON=python:PYTHON=python2:' Makefile
-
- make
-}
-
-package() {
- cd "${srcdir}/${pkgname}-${pkgname}-${_pkgver}"
- make DESTDIR=$pkgdir install
-}
-