summaryrefslogtreecommitdiff
path: root/pcr/ocaml-pcre/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pcr/ocaml-pcre/PKGBUILD')
-rw-r--r--pcr/ocaml-pcre/PKGBUILD34
1 files changed, 0 insertions, 34 deletions
diff --git a/pcr/ocaml-pcre/PKGBUILD b/pcr/ocaml-pcre/PKGBUILD
deleted file mode 100644
index bfc214b28..000000000
--- a/pcr/ocaml-pcre/PKGBUILD
+++ /dev/null
@@ -1,34 +0,0 @@
-# Contributor: Serge Zirukin <ftrvxmtrx@gmail.com>
-# Contributor: Sergei Lebedev <superbobry@gmail.com>
-# Contributor: Magnus Therning <magnus@therning.org>
-# Maintainer : Parabola GNU / Linux-libre <aurelien@cwb.io>
-
-pkgname=ocaml-pcre
-pkgver=7.0.2
-pkgrel=2
-pkgdesc="Perl compatible regular expressions for OCaml"
-arch=('i686' 'x86_64')
-url="http://www.ocaml.info/home/ocaml_sources.html#toc18"
-license=('LGPL')
-depends=('ocaml' 'pcre>=4.5')
-makedepends=('ocaml-findlib')
-replaces=('pcre-ocaml')
-conflicts=('pcre-ocaml')
-source=("https://bitbucket.org/mmottl/pcre-ocaml/downloads/pcre-ocaml-$pkgver.tar.gz")
-md5sums=('412eec5674a8bab76ccd09e006a24e10')
-options=(!strip)
-
-build() {
- cd "$srcdir/pcre-ocaml-$pkgver"
-
- ./configure --disable-debug --prefix /usr --destdir "$pkgdir"
- make all
-}
-
-package() {
- cd "$srcdir/pcre-ocaml-$pkgver"
- export OCAMLFIND_DESTDIR="$pkgdir$(ocamlfind printconf destdir)"
- install -dm 755 "$OCAMLFIND_DESTDIR/stublibs"
- make install
- install -Dm 644 COPYING.txt "$pkgdir/usr/share/licenses/$pkgname/COPYING"
-}