summaryrefslogtreecommitdiff
path: root/~fauno/vala-notmuch/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to '~fauno/vala-notmuch/PKGBUILD')
-rw-r--r--~fauno/vala-notmuch/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/~fauno/vala-notmuch/PKGBUILD b/~fauno/vala-notmuch/PKGBUILD
new file mode 100644
index 000000000..0e97683a4
--- /dev/null
+++ b/~fauno/vala-notmuch/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Mark Foxwell fastfret79@archlinux.org.uk
+
+pkgname=vala-notmuch
+pkgver=20120112
+pkgrel=1
+pkgdesc="a notmuch address book in vala"
+url="https://github.com/spaetz/vala-notmuch"
+arch=('i686' 'x86_64' 'mips64el')
+license=('GPL2')
+makedepends=('vala')
+depends=('notmuch')
+install=vala-notmuch.install
+source=("https://repo.parabolagnulinux.org/other/${pkgname}-${pkgver}-${pkgrel}-any.src.tar.xz")
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}/src"
+
+ ./make
+
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ install -D -m755 src/addrlookup ${pkgdir}/usr/bin/addrlookup
+
+}
+
+# vim:set ts=2 sw=2 et:
+md5sums=('99e264c0cb36e0a0f18048fb2ebd07e0')
+md5sums=('ca73980225368309119cf17ff5b3f3c4')